summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-05-09 18:51:43 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-05-09 18:51:43 +0200
commit384128db5929c50cd1675f04855d660ef0a8a03b (patch)
tree37ec4925b1e8d90d20297ad8d304097c2f473063
parentad23ac3beb2d2cc691ddeb9555ed5556832f487a (diff)
downloadpackages-384128db5929c50cd1675f04855d660ef0a8a03b.tar.xz
community/ponyc: accept failing tests
-rw-r--r--community/ponyc/PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/ponyc/PKGBUILD b/community/ponyc/PKGBUILD
index 036ee228..2e505e1e 100644
--- a/community/ponyc/PKGBUILD
+++ b/community/ponyc/PKGBUILD
@@ -11,4 +11,9 @@ eval "$(
# the compiler seems fine, but the test frameworks seems to break with
# newer LLVM, for now, ignoring the tests:
# https://github.com/ponylang/ponyc/issues/2875
-unset check
+eval "$(
+ declare -f check | \
+ sed '
+ s/\(make.*\)/\1 || true/
+ '
+)"