summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-04-24 20:34:03 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-04-24 20:34:03 +0200
commit106ece85bbe0ec3920f06ef7d0b7d447c294a044 (patch)
tree87e59f4a1578b51b3c9f7812510f7092bdcccc7b
parent358f2102fa76c8b5b2765b1adc28bcbbeab61d48 (diff)
downloadpackages-106ece85bbe0ec3920f06ef7d0b7d447c294a044.tar.xz
extra/librsvg-og: temporary hotfix for breaking API changes
-rw-r--r--extra/librsvg-og/PKGBUILD (renamed from community/librsvg-og/PKGBUILD)29
1 files changed, 21 insertions, 8 deletions
diff --git a/community/librsvg-og/PKGBUILD b/extra/librsvg-og/PKGBUILD
index 7ec1b843..215cf59a 100644
--- a/community/librsvg-og/PKGBUILD
+++ b/extra/librsvg-og/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
pkgname=librsvg-og
-pkgver=2.40.20
-pkgrel=1
+pkgver=2.40.20+20+g79890f60
+pkgrel=2
epoch=1
pkgdesc="SVG rendering library old gen"
url="https://github.com/oaken-source/librsvg-og"
@@ -12,16 +12,27 @@ depends=(gdk-pixbuf2 pango libcroco)
conflicts_i486=(libsrvg)
makedepends=(gobject-introspection gtk-doc git)
provides_i486=(librsvg=${pkgver} librsvg-${pkgver%%.*}.so)
-source=("https://github.com/oaken-source/librsvg-og/archive/2.40.20.tar.gz")
-sha256sums=('5bcbd8aa34a81478f990dc62a308ee2a42ff89a4e2bc905c09fd68f525bf5643')
+#source=("https://github.com/oaken-source/librsvg-og/archive/2.40.20.tar.gz")
+_commit=79890f607a8e489e631708fe16ffbaf52780960a # branch api2
+source=("git+https://github.com/andreasbaumann/librsvg-og.git#commit=$_commit")
+
+#sha256sums=('5bcbd8aa34a81478f990dc62a308ee2a42ff89a4e2bc905c09fd68f525bf5643')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/^orc-//;s/-/+/g'
+}
prepare() {
- cd ${pkgname}-${pkgver}
+# cd ${pkgname}-${pkgver}
+ cd $pkgname
NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd ${pkgname}-${pkgver}
+# cd ${pkgname}-${pkgver}
+ cd $pkgname
./configure --prefix=/usr --disable-static --disable-vala \
--enable-gtk-doc
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' libtool
@@ -29,13 +40,15 @@ build() {
}
check() {
- cd ${pkgname}-${pkgver}
+# cd ${pkgname}-${pkgver}
+ cd $pkgname
# Test suite is very dependent on the versions of
# Cairo, Pango, FreeType and HarfBuzz
make check || :
}
package() {
- cd ${pkgname}-${pkgver}
+# cd ${pkgname}-${pkgver}
+ cd $pkgname
make DESTDIR="$pkgdir" install
}