summaryrefslogtreecommitdiff
path: root/test/pacman/tests/Makefile.am
diff options
context:
space:
mode:
authorAndrew Gregory <andrew.gregory.8@gmail.com>2015-02-09 01:58:02 -0500
committerAllan McRae <allan@archlinux.org>2015-02-12 13:22:24 +1000
commitc3161925c29ef3dcfbb66648a91ecc50c7a0492d (patch)
tree8626fb4d156d610d29a38b32dace19cad288b732 /test/pacman/tests/Makefile.am
parent10fc538c70bf84f64881403f964ff4d6651268b3 (diff)
downloadpacman-c3161925c29ef3dcfbb66648a91ecc50c7a0492d.tar.xz
sync200.py.in: remove unused substitution
LIBCURL was never set in the Makefile so XferCommand was always being set in the test file. This removes the only substitution in our test files which will prevent the TESTS file from being rebuilt every time configure is run. Signed-off-by: Andrew Gregory <andrew.gregory.8@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'test/pacman/tests/Makefile.am')
-rw-r--r--test/pacman/tests/Makefile.am20
1 files changed, 1 insertions, 19 deletions
diff --git a/test/pacman/tests/Makefile.am b/test/pacman/tests/Makefile.am
index dba84e3d..b541b3d6 100644
--- a/test/pacman/tests/Makefile.am
+++ b/test/pacman/tests/Makefile.am
@@ -1,25 +1,7 @@
-CONFTESTS = $(patsubst %py.in,%py,$(wildcard *.py.in))
-
-check_SCRIPTS = \
- $(wildcard *.py) \
- $(CONFTESTS)
+check_SCRIPTS = $(wildcard *.py)
noinst_SCRIPTS = $(check_SCRIPTS)
EXTRA_DIST = $(check_SCRIPTS)
-CLEANFILES = $(CONFTESTS)
-
-#### Taken from the autoconf scripts Makefile.am ####
-edit = sed \
- -e 's|@LIBCURL[@]|$(LIBCURL)|g' \
- -e 's|@configure_input[@]|Generated from $@.in; do not edit by hand.|g'
-
-
-$(CONFTESTS): Makefile
- $(AM_V_at)$(RM) $@ $@.tmp
- $(AM_V_GEN)test -f $(srcdir)/$@.in && $(edit) $(srcdir)/$@.in >$@.tmp || true
- $(AM_V_at)chmod a-w $@.tmp
- $(AM_V_at)mv $@.tmp $@
-
# vim:set noet: