summaryrefslogtreecommitdiff
path: root/scripts/meson.build
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2019-05-07 21:55:03 -0400
committerAllan McRae <allan@archlinux.org>2019-05-08 12:46:33 +1000
commit9375f49865296f04bd51e5e39ddca863b67cbd6c (patch)
treed2100c12c83236176ad931179a70495eb7f9a221 /scripts/meson.build
parent614ef781ebf8ef7ae116c26d419bc9002c162599 (diff)
downloadpacman-9375f49865296f04bd51e5e39ddca863b67cbd6c.tar.xz
libmakepkg: install pkg-config file
Since makepkg exports a public library of functions, other projects may wish to use these functions. Highlights include parseopts or our messaging functions. Install a pkg-config file in order to let downstream users detect where they can source the libmakepkg functionality. This is useful e.g. to gracefully handle the case where a thirdparty project is configured and installed into a different datarootdir from pacman, but still wants to use the installed pacman's version of libmakepkg. Signed-off-by: Eli Schwartz <eschwartz@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'scripts/meson.build')
-rw-r--r--scripts/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/scripts/meson.build b/scripts/meson.build
index db442973..7d533f35 100644
--- a/scripts/meson.build
+++ b/scripts/meson.build
@@ -78,6 +78,12 @@ endforeach
subdir('libmakepkg')
+configure_file(
+ configuration : { 'libmakepkgdir': LIBMAKEPKGDIR, 'PACKAGE_VERSION': PACKAGE_VERSION },
+ input : 'libmakepkg.pc.in',
+ output : '@BASENAME@',
+ install_dir : join_paths(DATAROOTDIR, 'pkgconfig'))
+
custom_target(
'bash_completion',
command : [ SCRIPT_EDITOR, '@INPUT@', '@OUTPUT@' ],