summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2018-05-29 00:08:38 -0400
committerAllan McRae <allan@archlinux.org>2018-08-10 12:37:19 +1000
commitfd16da2ed68aa7f89ad37701bcf7674b7bb14b2d (patch)
tree3a0f1337c50cd0ff4431b9fee4537ebd76f8c276 /scripts/Makefile.am
parent7e081d2adf8321f25165255fd21fab61d4055a53 (diff)
downloadpacman-fd16da2ed68aa7f89ad37701bcf7674b7bb14b2d.tar.xz
scripts/completion: derive the bash completion directory from pkg-config
Default to the standard completionsdir, which is lazy-loaded, rather than hardcoding the compatdir which is not. Signed-off-by: Eli Schwartz <eschwartz@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index f759e149..f83e16c0 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -246,13 +246,18 @@ $(WRAPPER): \
$(AM_V_at)$(LN_S) $@ $(subst -wrapper,,$@)
install-data-local:
- $(MKDIR_P) $(DESTDIR)$(sysconfdir)/bash_completion.d/
- $(INSTALL_DATA) completion/bash_completion $(DESTDIR)$(sysconfdir)/bash_completion.d/pacman
+ $(MKDIR_P) $(DESTDIR)$(bashcompdir)
+ $(INSTALL_DATA) completion/bash_completion $(DESTDIR)/$(bashcompdir)/pacman
+ for completion in makepkg pacman-key; do \
+ $(LN_S) pacman $(DESTDIR)/$(bashcompdir)/$$completion; \
+ done
$(MKDIR_P) $(DESTDIR)$(datarootdir)/zsh/site-functions/
$(INSTALL_DATA) completion/zsh_completion $(DESTDIR)$(datarootdir)/zsh/site-functions/_pacman
uninstall-local:
- $(RM) $(DESTDIR)$(sysconfdir)/bash_completion.d/pacman
+ $(RM) $(DESTDIR)$(bashcompdir)/makepkg
+ $(RM) $(DESTDIR)$(bashcompdir)/pacman
+ $(RM) $(DESTDIR)$(bashcompdir)/pacman-key
$(RM) $(DESTDIR)$(datarootdir)/zsh/site-functions/_pacman
install-exec-hook: