summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2018-03-14 22:59:18 -0400
committerAllan McRae <allan@archlinux.org>2018-03-15 14:34:13 +1000
commitf054351e528eebf985378f2f4cb0f621ca15023d (patch)
tree93f292b864923dbee5365962bbbf2f19025d74c5 /scripts/Makefile.am
parent9c8d7a80932e23baed1fc247b56b4c5725f9eff4 (diff)
downloadpacman-f054351e528eebf985378f2f4cb0f621ca15023d.tar.xz
libmakepkg: Add basic rules to lint makepkg.conf variables
Currently the only things we check are: - Things that should be arrays, are not strings, and vice versa (this was mostly copy-pasted from the similar code in lint_pkgbuild). - Variables that are meant to contain pathname components cannot contain a newline character, because newline characters in pathnames are weird and also don't play well with future changes intended for the --packagelist option. Signed-off-by: Eli Schwartz <eschwartz@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 8cf79f21..7fe169b3 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -44,6 +44,7 @@ libmakepkgdir = $(datarootdir)/makepkg
LIBMAKEPKGDIRS = \
integrity \
+ lint_config \
lint_package \
lint_pkgbuild \
source \
@@ -56,6 +57,9 @@ LIBMAKEPKG_IN = \
libmakepkg/integrity/generate_signature.sh \
libmakepkg/integrity/verify_checksum.sh \
libmakepkg/integrity/verify_signature.sh \
+ libmakepkg/lint_config.sh \
+ libmakepkg/lint_config/paths.sh \
+ libmakepkg/lint_config/variable.sh \
libmakepkg/lint_package.sh \
libmakepkg/lint_package/build_references.sh \
libmakepkg/lint_package/dotfiles.sh \