summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2018-06-28 13:19:43 -0400
committerAllan McRae <allan@archlinux.org>2018-10-21 20:22:19 +1000
commitb5d62d2c91a2caf5c18945921cdf12af6f36b2d4 (patch)
tree9e127c1174be7a72de4b059c7128990782a5902d /scripts/Makefile.am
parent3561c872ca0980c76442fcbf3985cc92a8f572f7 (diff)
downloadpacman-b5d62d2c91a2caf5c18945921cdf12af6f36b2d4.tar.xz
Port scripts to use libmakepkg's messaging code.
Remove all remnants of library/{output_format,term_colors}.sh Signed-off-by: Eli Schwartz <eschwartz@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am20
1 files changed, 5 insertions, 15 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 462962e1..c6b6220e 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -35,10 +35,8 @@ EXTRA_DIST = \
$(LIBMAKEPKG_DIST)
LIBRARY = \
- library/output_format.sh \
library/human_to_size.sh \
- library/size_to_human.sh \
- library/term_colors.sh
+ library/size_to_human.sh
libmakepkgdir = $(datarootdir)/makepkg
@@ -205,21 +203,13 @@ makepkg-template: \
$(AM_V_GEN)$(edit) $< > $@
$(AM_V_at)chmod +x,a-w $@
-pacman-db-upgrade: \
- $(srcdir)/pacman-db-upgrade.sh.in \
- $(srcdir)/library/output_format.sh
+pacman-db-upgrade: $(srcdir)/pacman-db-upgrade.sh.in
-pacman-key: \
- $(srcdir)/pacman-key.sh.in \
- $(srcdir)/library/output_format.sh
+pacman-key: $(srcdir)/pacman-key.sh.in
-pkgdelta: \
- $(srcdir)/pkgdelta.sh.in \
- $(srcdir)/library/output_format.sh
+pkgdelta: $(srcdir)/pkgdelta.sh.in
-repo-add: \
- $(srcdir)/repo-add.sh.in \
- $(srcdir)/library/output_format.sh
+repo-add: $(srcdir)/repo-add.sh.in
repo-remove: $(srcdir)/repo-add.sh.in
$(AM_V_at)$(RM) repo-remove