summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorAlad Wenter <alad@archlinux.info>2016-10-10 10:47:38 +0200
committerAllan McRae <allan@archlinux.org>2016-10-22 20:50:54 +1000
commit1f8f0bd9ac4c11cdc1b9506f9f64d8192ecad4ee (patch)
tree209a9b9e48a558b8b75ff062e4f86d86cb29df95 /scripts/Makefile.am
parentdfc78129be7acaa0ebe71fe407d63b5141c10150 (diff)
downloadpacman-1f8f0bd9ac4c11cdc1b9506f9f64d8192ecad4ee.tar.xz
makepkg: Move parseopts from library to libmakepkg
parseopts is used in makepkg and other scripts such as pacman-key as a getopt replacement. Instead of including it in those scripts via a macro, move it to libmakepkg/util/parseopts.sh and have scripts source this file where appropriate. To keep the parseopts test, a new variable was introduced: PM_LIBMAKEPKG_DIR Signed-off-by: Alad Wenter <alad@archlinux.info> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 3863a2c1..448057dc 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -36,7 +36,6 @@ EXTRA_DIST = \
LIBRARY = \
library/output_format.sh \
- library/parseopts.sh \
library/human_to_size.sh \
library/size_to_human.sh \
library/term_colors.sh
@@ -97,6 +96,7 @@ LIBMAKEPKG_IN = \
libmakepkg/util.sh \
libmakepkg/util/message.sh \
libmakepkg/util/option.sh \
+ libmakepkg/util/parseopts.sh \
libmakepkg/util/pkgbuild.sh \
libmakepkg/util/source.sh \
libmakepkg/util/util.sh
@@ -105,7 +105,10 @@ LIBMAKEPKG_DIST = \
$(addsuffix .in, $(LIBMAKEPKG_IN))
WRAPPER = \
- makepkg-wrapper
+ makepkg-wrapper \
+ pacman-db-upgrade-wrapper \
+ pacman-key-wrapper \
+ pkgdelta-wrapper
COMPLETION_IN = \
completion/bash_completion \
@@ -180,7 +183,6 @@ all-am: $(COMPLETION_IN)
makepkg: \
$(srcdir)/makepkg.sh.in \
$(srcdir)/wrapper.sh.in \
- $(srcdir)/library/parseopts.sh \
$(LIBMAKEPKG_IN)
makepkg-template: \
@@ -197,13 +199,11 @@ pacman-db-upgrade: \
pacman-key: \
$(srcdir)/pacman-key.sh.in \
- $(srcdir)/library/output_format.sh \
- $(srcdir)/library/parseopts.sh
+ $(srcdir)/library/output_format.sh
pkgdelta: \
$(srcdir)/pkgdelta.sh.in \
- $(srcdir)/library/output_format.sh \
- $(srcdir)/library/parseopts.sh
+ $(srcdir)/library/output_format.sh
repo-add: \
$(srcdir)/repo-add.sh.in \