summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2018-06-19 16:26:33 -0400
committerAllan McRae <allan@archlinux.org>2018-08-10 12:37:20 +1000
commitb0a8f44f105e0ac0f18279e3c25d570090ac9e70 (patch)
tree4964b3f0b5e3c886fb7d0825bfe8fa77817b4607 /configure.ac
parent885bbb504afbf014194c8c20a51fc862980da45b (diff)
downloadpacman-b0a8f44f105e0ac0f18279e3c25d570090ac9e70.tar.xz
configure: bump the minimum version of bash to 4.4
This is required in order to use declare -g and ${var@a} Signed-off-by: Eli Schwartz <eschwartz@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 07bdc105..5ca5bdd0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -193,18 +193,18 @@ AC_DEFUN([AX_PROG_PERL_VERSION],
AX_PROG_PERL_VERSION([5.10.1], [], [AC_MSG_ERROR([perl is too old])])
AS_IF([test "x$BASH_SHELL" = "xfalse"],
- AC_MSG_WARN([*** bash >= 4.1.0 is required for pacman scripts]),
+ AC_MSG_WARN([*** bash >= 4.4.0 is required for pacman scripts]),
[bash_version_major=`$BASH_SHELL -c 'echo "${BASH_VERSINFO[[0]]}"'`
bash_version_minor=`$BASH_SHELL -c 'echo "${BASH_VERSINFO[[1]]}"'`
ok=yes
if test "$bash_version_major" -lt 4; then
ok=no
fi
- if test "$bash_version_major" -eq 4 && test "$bash_version_minor" -lt 1; then
+ if test "$bash_version_major" -eq 4 && test "$bash_version_minor" -lt 4; then
ok=no
fi
if test "$ok" = "no"; then
- AC_MSG_ERROR([*** bash >= 4.1.0 is required for pacman scripts])
+ AC_MSG_ERROR([*** bash >= 4.4.0 is required for pacman scripts])
fi
unset bash_version_major bash_version_minor ok])