summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2018-08-19 21:12:33 -0400
committerAndrew Gregory <andrew.gregory.8@gmail.com>2018-10-18 18:05:19 -0700
commitafb9c0140fd6949ede64cc1a304e9349772fca04 (patch)
tree6995c7eb8f090f5af64ae6219f872b42db2eb9d3 /configure.ac
parentffde85aadfe0e08fb710102d0a547335e9d1a200 (diff)
downloadpacman-afb9c0140fd6949ede64cc1a304e9349772fca04.tar.xz
Port pactest to python3
Use BytesIO instead of StringIO, and ensure that we unicode-encode data where needed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a569ffeb..c369ca74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -179,7 +179,7 @@ AC_SUBST(LFS_CFLAGS)
AC_PROG_AWK
AC_PROG_CC_C99
AC_PROG_INSTALL
-AC_CHECK_PROGS([PYTHON], [python2.7 python2 python], [false])
+AC_CHECK_PROGS([PYTHON], [python3 python], [false])
AC_PATH_PROGS([BASH_SHELL], [bash bash4], [false])
# check for perl 5.10.1 (needed by makepkg-template)