summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2018-04-16 18:12:59 -0400
committerAllan McRae <allan@archlinux.org>2018-04-29 21:57:17 +1000
commitab7393c53edb3a399751aa41b5c8693157ae0aa3 (patch)
tree18320d2bbe8dbcd58c1ef68e9573c61e5e04e6c6 /configure.ac
parent91b72cc386ca03241791748da5da2b150c724ace (diff)
downloadpacman-ab7393c53edb3a399751aa41b5c8693157ae0aa3.tar.xz
libalpm.pc: migrate to Requires.private
pkg-config has built-in dependency handling, but we currently insert the raw $LIBS into libalpm's own linker flags and fail to handle Cflags at all. For dependencies which support pkg-config, simply use that instead. Signed-off-by: Eli Schwartz <eschwartz@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8c526e3..4d2f7d34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -223,12 +223,14 @@ PKG_CHECK_MODULES(LIBARCHIVE, [libarchive >= 3.0.0], ,
have_openssl=no
have_nettle=no
if test "x$with_crypto" = "xnettle"; then
+ AC_SUBST(pc_crypto, [nettle])
PKG_CHECK_MODULES(NETTLE, [nettle],
[AC_DEFINE(HAVE_LIBNETTLE, 1, [Define whether to use nettle]) have_nettle=yes], have_nettle=no)
if test "x$have_nettle" = xno -a "x$with_crypto" = xnettle; then
AC_MSG_ERROR([*** nettle support requested but libraries not found])
fi
else if test "x$with_crypto" = "xopenssl"; then
+ AC_SUBST(pc_crypto, [libcrypto])
PKG_CHECK_MODULES(LIBSSL, [libcrypto],
[AC_DEFINE(HAVE_LIBSSL, 1, [Define if libcrypto is available]) have_openssl=yes], have_openssl=no)
if test "x$have_openssl" = xno; then
@@ -251,6 +253,10 @@ if test "x$with_libcurl" != "xno"; then
fi
fi
AM_CONDITIONAL(HAVE_LIBCURL, [test "$have_libcurl" = "yes"])
+# used to generate libalpm.pc
+if test "x$have_libcurl" = xyes; then
+ AC_SUBST(pc_libcurl, [libcurl])
+fi
# Check for gpgme
AC_MSG_CHECKING(whether to link with libgpgme)