summaryrefslogtreecommitdiff
path: root/PKGBUILD-split.proto
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2011-06-25 16:45:01 -0400
committerDan McGee <dan@archlinux.org>2011-06-30 13:37:58 -0500
commit6633b8e5c290dbb1b0382f3f960e1f7134247a68 (patch)
tree3d7021ecc7b2d1d9121bcd8e062deab12ef3b745 /PKGBUILD-split.proto
parent98a2fc8deba6be37729c26cf68e9927f6466c95e (diff)
downloadpacman-6633b8e5c290dbb1b0382f3f960e1f7134247a68.tar.xz
move proto files to new subdirectory, proto/
Signed-off-by: Dave Reisner <dreisner@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'PKGBUILD-split.proto')
-rw-r--r--PKGBUILD-split.proto70
1 files changed, 0 insertions, 70 deletions
diff --git a/PKGBUILD-split.proto b/PKGBUILD-split.proto
deleted file mode 100644
index 52aacc54..00000000
--- a/PKGBUILD-split.proto
+++ /dev/null
@@ -1,70 +0,0 @@
-# This is an example of a PKGBUILD for splitting packages. Use this as a
-# start to creating your own, and remove these comments. For more information,
-# see 'man PKGBUILD'. NOTE: Please fill out the license field for your package!
-# If it is unknown, then please put 'unknown'.
-
-# Maintainer: Your Name <youremail@domain.com>
-pkgname=('pkg1' 'pkg2')
-pkgbase=BASE
-pkgver=VERSION
-pkgrel=1
-epoch=
-pkgdesc=""
-arch=()
-url=""
-license=('GPL')
-groups=()
-depends=()
-makedepends=()
-checkdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=($pkgbase-$pkgver.tar.gz)
-noextract=()
-md5sums=() #generate with 'makepkg -g'
-
-build() {
- cd "$srcdir/$pkgbase-$pkgver"
- ./configure --prefix=/usr
- make
-}
-
-check() {
- cd "$srcdir/$pkgname-$pkgver"
- make -k check
-}
-
-package_pkg1() {
- # options and directives that can be overridden
- pkgver=
- pkgrel=
- pkgdesc=""
- arch=()
- license=()
- groups=()
- depends=()
- optdepends=()
- provides=()
- conflicts=()
- replaces=()
- backup=()
- options=()
- install=
- changelog=
-
- cd "$srcdir/$pkgbase-$pkgver"
- make DESTDIR="$pkgdir/" install-pkg1
-}
-
-package_pkg2() {
- # options and directives overrides
- pkgdesc=""
-
- cd "$srcdir/$pkgbase-$pkgver"
- make DESTDIR="$pkgdir/" install-pkg2
-}