summaryrefslogtreecommitdiff
path: root/PKGBUILD-split.proto
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2009-01-16 19:45:02 -0600
committerDan McGee <dan@archlinux.org>2009-01-16 19:45:02 -0600
commit3d49d88009341d5cacbbe08fb4f6f6af3ed76ae1 (patch)
tree968ee9b752f02af850494df1c7197f21a9e2f33d /PKGBUILD-split.proto
parenta9f030e84c96d57fbcbc7e8af5fc897515ef79e7 (diff)
parente946ee7745a839c0cd9244a3d9b50a3ea15143f9 (diff)
downloadpacman-3d49d88009341d5cacbbe08fb4f6f6af3ed76ae1.tar.xz
Merge branch 'am/splitpkg'
* am/splitpkg: makepkg: implement creation of split packages makepkg: Optional argument for run_package and create_package makepkg: hack around tee in run_package function makepkg: add functions for backup and restore of package fields makepkg: add optional package function makepkg: Add PKGBUILD-split.proto
Diffstat (limited to 'PKGBUILD-split.proto')
-rw-r--r--PKGBUILD-split.proto55
1 files changed, 55 insertions, 0 deletions
diff --git a/PKGBUILD-split.proto b/PKGBUILD-split.proto
new file mode 100644
index 00000000..35fb22b9
--- /dev/null
+++ b/PKGBUILD-split.proto
@@ -0,0 +1,55 @@
+# This is an example of a PKGBUILD for splitting packages. Use this as a
+# start to creating your own, and remove these comments. For more information,
+# see 'man PKGBUILD'. NOTE: Please fill out the license field for your package!
+# If it is unknown, then please put 'unknown'.
+
+# Contributor: Your Name <youremail@domain.com>
+pkgname=('pkg1' 'pkg2')
+pkgver=VERSION
+pkgrel=1
+pkgdesc=""
+arch=()
+url=""
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=($pkgname-$pkgver.tar.gz)
+noextract=()
+md5sums=() #generate with 'makepkg -g'
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package_pkg1() {
+ # options and directives that can be overridden
+ pkgdesc=""
+ license=()
+ groups=()
+ depends=()
+ optdepends=()
+ provides=()
+ conflicts=()
+ replaces=()
+ backup=()
+ options=()
+ install=
+
+ make DESTDIR="$pkgdir/" install-pkg1
+}
+
+package_pkg2() {
+ # options and directives overrides
+ pkgdesc=""
+
+ make DESTDIR="$pkgdir/" install-pkg2
+}