summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/qt5-declarative/PKGBUILD12
-rw-r--r--extra/qt5-declarative/qtdeclarative-everywhere-src-5.12.3-no-sse2-non-fatal.patch16
2 files changed, 0 insertions, 28 deletions
diff --git a/extra/qt5-declarative/PKGBUILD b/extra/qt5-declarative/PKGBUILD
deleted file mode 100644
index 387fb122..00000000
--- a/extra/qt5-declarative/PKGBUILD
+++ /dev/null
@@ -1,12 +0,0 @@
-# disable croaking about missing SSE2 for WASM (web assemblies) when
-# instantiating a Javascript engine
-
-source+=(qtdeclarative-everywhere-src-5.12.3-no-sse2-non-fatal.patch)
-sha256sums+=('5dce1799db9c4bca10006eb4a4980ffa74d6da5b18ab02f31a5267c44338b765')
-
-eval "$(
- declare -f prepare | \
- sed '
- /cd/a if [ "${CARCH}" != "pentium4" ]; then patch -Np1 -i ../qtdeclarative-everywhere-src-5.12.3-no-sse2-non-fatal.patch; fi
- '
-)"
diff --git a/extra/qt5-declarative/qtdeclarative-everywhere-src-5.12.3-no-sse2-non-fatal.patch b/extra/qt5-declarative/qtdeclarative-everywhere-src-5.12.3-no-sse2-non-fatal.patch
deleted file mode 100644
index 7af11f4b..00000000
--- a/extra/qt5-declarative/qtdeclarative-everywhere-src-5.12.3-no-sse2-non-fatal.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -rauN qtdeclarative-everywhere-src-5.12.3/src/qml/qml/v8/qv8engine.cpp qtdeclarative-everywhere-src-5.12.3-no-sse2-non-fatal-patch/src/qml/qml/v8/qv8engine.cpp
---- qtdeclarative-everywhere-src-5.12.3/src/qml/qml/v8/qv8engine.cpp 2019-04-08 11:12:26.000000000 +0200
-+++ qtdeclarative-everywhere-src-5.12.3-no-sse2-non-fatal-patch/src/qml/qml/v8/qv8engine.cpp 2019-06-12 14:48:14.189999439 +0200
-@@ -140,9 +140,9 @@
- {
- #ifndef Q_OS_WASM // wasm does not have working simd QTBUG-63924
- #ifdef Q_PROCESSOR_X86_32
-- if (!qCpuHasFeature(SSE2)) {
-- qFatal("This program requires an X86 processor that supports SSE2 extension, at least a Pentium 4 or newer");
-- }
-+ //~ if (!qCpuHasFeature(SSE2)) {
-+ //~ qFatal("This program requires an X86 processor that supports SSE2 extension, at least a Pentium 4 or newer");
-+ //~ }
- #endif
- #endif
-