summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/boost/PKGBUILD7
-rw-r--r--extra/cmake/PKGBUILD20
-rw-r--r--extra/flac/PKGBUILD5
-rw-r--r--extra/git/PKGBUILD18
-rw-r--r--extra/jsoncpp/PKGBUILD18
-rw-r--r--extra/libunwind/PKGBUILD5
-rw-r--r--extra/libuv/PKGBUILD20
-rw-r--r--extra/mariadb/PKGBUILD11
-rw-r--r--extra/meson/PKGBUILD6
-rw-r--r--extra/namcap/PKGBUILD4
-rw-r--r--extra/nasm/PKGBUILD20
-rw-r--r--extra/pyopenssl/PKGBUILD6
-rw-r--r--extra/python-appdirs/PKGBUILD5
-rw-r--r--extra/python-asn1crypto/PKGBUILD5
-rw-r--r--extra/python-attrs/PKGBUILD5
-rw-r--r--extra/python-cffi/PKGBUILD5
-rw-r--r--extra/python-chardet/PKGBUILD5
-rw-r--r--extra/python-cryptography/PKGBUILD5
-rw-r--r--extra/python-idna/PKGBUILD4
-rw-r--r--extra/python-lxml/PKGBUILD4
-rw-r--r--extra/python-markupsafe/PKGBUILD5
-rw-r--r--extra/python-packaging/PKGBUILD5
-rw-r--r--extra/python-pip/PKGBUILD7
-rw-r--r--extra/python-ply/PKGBUILD5
-rw-r--r--extra/python-pyasn1/PKGBUILD5
-rw-r--r--extra/python-pycparser/PKGBUILD5
-rw-r--r--extra/python-pyparsing/PKGBUILD54
-rw-r--r--extra/python-requests/PKGBUILD5
-rw-r--r--extra/python-retrying/PKGBUILD5
-rw-r--r--extra/python-setuptools/PKGBUILD5
-rw-r--r--extra/python-six/PKGBUILD5
-rw-r--r--extra/python-urllib3/PKGBUILD18
-rw-r--r--extra/python/PKGBUILD26
-rw-r--r--extra/python2-ipaddress/PKGBUILD5
-rw-r--r--extra/python2/PKGBUILD35
-rw-r--r--extra/valgrind/PKGBUILD9
-rw-r--r--extra/w3m/PKGBUILD5
37 files changed, 382 insertions, 0 deletions
diff --git a/extra/boost/PKGBUILD b/extra/boost/PKGBUILD
new file mode 100644
index 00000000..e2ce4fe0
--- /dev/null
+++ b/extra/boost/PKGBUILD
@@ -0,0 +1,7 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no openmpi, no numpy
+ makedepends=(${makedepends[@]//openmpi/})
+ makedepends=(${makedepends[@]//python-numpy/})
+ makedepends=(${makedepends[@]//python2-numpy/})
+fi
diff --git a/extra/cmake/PKGBUILD b/extra/cmake/PKGBUILD
new file mode 100644
index 00000000..d1758858
--- /dev/null
+++ b/extra/cmake/PKGBUILD
@@ -0,0 +1,20 @@
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no Python Shinx
+ makedepends=(${makedepends[@]//python-sphinx/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--sphinx-man//
+ '
+ )"
+
+ # no Qt5 GUI
+ makedepends=(${makedepends[@]//qt5-base/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--qt-gui//
+ '
+ )"
+fi
diff --git a/extra/flac/PKGBUILD b/extra/flac/PKGBUILD
new file mode 100644
index 00000000..d609efe0
--- /dev/null
+++ b/extra/flac/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # disable documentation
+ makedepends=(${makedepends[@]//doxygen/})
+fi
diff --git a/extra/git/PKGBUILD b/extra/git/PKGBUILD
new file mode 100644
index 00000000..d78c5181
--- /dev/null
+++ b/extra/git/PKGBUILD
@@ -0,0 +1,18 @@
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # we currently have no Gnome and libsecret, so disable integration
+ makedepends=(${makedepends[@]//libgnome-keyring/})
+ makedepends=(${makedepends[@]//libsecret/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s@\(make -C contrib/credential/gnome-keyring\)@#\1@
+ s@\(make -C contrib/credential/libsecret\)@#\1@
+ '
+ declare -f package | \
+ sed '
+ /gnome-keyring/d
+ /libsecret/d
+ '
+ )"
+fi
diff --git a/extra/jsoncpp/PKGBUILD b/extra/jsoncpp/PKGBUILD
new file mode 100644
index 00000000..a9b60ed8
--- /dev/null
+++ b/extra/jsoncpp/PKGBUILD
@@ -0,0 +1,18 @@
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no doxygen or graphviz
+ makedepends=(${makedepends[@]//doxygen/})
+ makedepends=(${makedepends[@]//graphviz/})
+ eval "$(
+ declare -f build | \
+ sed '
+ /python doxybuild.py/d
+ '
+ declare -f package_jsoncpp-doc | \
+ sed '
+ /cp -a dist\/doxygen/d
+ '
+ )"
+fi
+
+
diff --git a/extra/libunwind/PKGBUILD b/extra/libunwind/PKGBUILD
new file mode 100644
index 00000000..8bf87ab2
--- /dev/null
+++ b/extra/libunwind/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no TeX for documentation
+ makedepends=(${makedepends[@]//texlive-core/})
+fi
diff --git a/extra/libuv/PKGBUILD b/extra/libuv/PKGBUILD
new file mode 100644
index 00000000..875804ad
--- /dev/null
+++ b/extra/libuv/PKGBUILD
@@ -0,0 +1,20 @@
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # archive link is wrong
+ source[0]="https://github.com/libuv/libuv/archive/v$pkgver.tar.gz"
+
+ # no python sphinx
+ makedepends=(${makedepends[@]//python-sphinx/})
+ eval "$(
+ declare -f build | \
+ sed '
+ /make man/d
+ '
+ declare -f package | \
+ sed '
+ /install.*libuv/d
+ '
+ )"
+fi
+
+
diff --git a/extra/mariadb/PKGBUILD b/extra/mariadb/PKGBUILD
index 9aa34220..3f6a4f9c 100644
--- a/extra/mariadb/PKGBUILD
+++ b/extra/mariadb/PKGBUILD
@@ -8,3 +8,14 @@ eval "$(
/patch -Np1.*openssl-1-1-0.patch/ a \ patch -Np1 -i "${srcdir}/mariadb-10.1.32-atomic.patch"
'
)"
+
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no java
+ eval "$(
+ declare -f build | \
+ sed '
+ s/cmake /cmake -DCONNECT_WITH_JDBC=0 /
+ '
+ )"
+fi
diff --git a/extra/meson/PKGBUILD b/extra/meson/PKGBUILD
index 5f193aa9..049f3375 100644
--- a/extra/meson/PKGBUILD
+++ b/extra/meson/PKGBUILD
@@ -5,3 +5,9 @@ eval "$(
s,./run_tests.py,./run_tests.py || true,
'
)"
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # too many dependencies
+ unset check
+fi
diff --git a/extra/namcap/PKGBUILD b/extra/namcap/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/extra/namcap/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/extra/nasm/PKGBUILD b/extra/nasm/PKGBUILD
new file mode 100644
index 00000000..f644e426
--- /dev/null
+++ b/extra/nasm/PKGBUILD
@@ -0,0 +1,20 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # remove all fonts and ghostscript (we don't build the manual)
+ makedepends=(${makedepends[@]//perl-font-ttf/})
+ makedepends=(${makedepends[@]//perl-sort-versions/})
+ makedepends=(${makedepends[@]//fontconfig/})
+ makedepends=(${makedepends[@]//adobe-source-sans-pro-fonts/})
+ makedepends=(${makedepends[@]//ttf-liberation/})
+ makedepends=(${makedepends[@]//ghostscript/})
+
+ eval "$(
+ declare -f build | \
+ sed '
+ /make .*doc/d
+ '
+ )"
+fi
+
+# orginal download link unstable
+#sed -i 's@http://www.nasm.us/pub/nasm/releasebuilds/${pkgver}/${pkgname}-${pkgver}.tar.xz@https://ftp.osuosl.org/pub/blfs/conglomeration/${pkgname}/${pkgname}-${pkgver}.tar.xz@' PKGBUILD
diff --git a/extra/pyopenssl/PKGBUILD b/extra/pyopenssl/PKGBUILD
new file mode 100644
index 00000000..4f2a85bf
--- /dev/null
+++ b/extra/pyopenssl/PKGBUILD
@@ -0,0 +1,6 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
+unset -f pkgver
diff --git a/extra/python-appdirs/PKGBUILD b/extra/python-appdirs/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-appdirs/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-asn1crypto/PKGBUILD b/extra/python-asn1crypto/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-asn1crypto/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-attrs/PKGBUILD b/extra/python-attrs/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-attrs/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-cffi/PKGBUILD b/extra/python-cffi/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-cffi/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-chardet/PKGBUILD b/extra/python-chardet/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-chardet/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-cryptography/PKGBUILD b/extra/python-cryptography/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-cryptography/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-idna/PKGBUILD b/extra/python-idna/PKGBUILD
new file mode 100644
index 00000000..3b5f7de0
--- /dev/null
+++ b/extra/python-idna/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+fi
diff --git a/extra/python-lxml/PKGBUILD b/extra/python-lxml/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/extra/python-lxml/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/extra/python-markupsafe/PKGBUILD b/extra/python-markupsafe/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-markupsafe/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-packaging/PKGBUILD b/extra/python-packaging/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-packaging/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-pip/PKGBUILD b/extra/python-pip/PKGBUILD
new file mode 100644
index 00000000..470a12fe
--- /dev/null
+++ b/extra/python-pip/PKGBUILD
@@ -0,0 +1,7 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
+
+
diff --git a/extra/python-ply/PKGBUILD b/extra/python-ply/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-ply/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-pyasn1/PKGBUILD b/extra/python-pyasn1/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-pyasn1/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-pycparser/PKGBUILD b/extra/python-pycparser/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-pycparser/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-pyparsing/PKGBUILD b/extra/python-pyparsing/PKGBUILD
new file mode 100644
index 00000000..e9913b6a
--- /dev/null
+++ b/extra/python-pyparsing/PKGBUILD
@@ -0,0 +1,54 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+
+ # subversion introduces a crazy amount of build dependencies, take
+ # official tarball
+ makedepends=(${makedepends[@]//subversion/})
+ source=('https://pypi.python.org/packages/3c/ec/a94f8cf7274ea60b5413df054f82a8980523efd712ec55a59e7c3357cf7c/pyparsing-2.2.0.tar.gz')
+
+ eval "$(
+ declare -f prepare | \
+ sed '
+ s/pyparsing_$pkgver/pyparsing-$pkgver/g
+ s,pyparsing-$pkgver/src,pyparsing-$pkgver,g
+ s,pyparsing-$pkgver-py2/src,pyparsing-$pkgver-py2,g
+ /sed/d
+ '
+ )"
+
+ eval "$(
+ declare -f build | \
+ sed '
+ s/pyparsing_$pkgver/pyparsing-$pkgver/g
+ s,pyparsing-$pkgver/src,pyparsing-$pkgver,g
+ s,pyparsing-$pkgver-py2/src,pyparsing-$pkgver-py2,g
+ '
+ )"
+
+ eval "$(
+ declare -f package_python-pyparsing | \
+ sed '
+ s/pyparsing_$pkgver/pyparsing-$pkgver/g
+ s,pyparsing-$pkgver/src,pyparsing-$pkgver,g
+ '
+ )"
+
+ eval "$(
+ declare -f package_python2-pyparsing | \
+ sed '
+ s/pyparsing_$pkgver/pyparsing-$pkgver/g
+ s,pyparsing-$pkgver-py2/src,pyparsing-$pkgver-py2,g
+ '
+ )"
+
+ # needed?
+ # remove a really weird sed
+ #sed -i 's/sed/#sed/g' PKGBUILD
+
+ unset check
+fi
+
+
+
diff --git a/extra/python-requests/PKGBUILD b/extra/python-requests/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-requests/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-retrying/PKGBUILD b/extra/python-retrying/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-retrying/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-setuptools/PKGBUILD b/extra/python-setuptools/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-setuptools/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-six/PKGBUILD b/extra/python-six/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python-six/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python-urllib3/PKGBUILD b/extra/python-urllib3/PKGBUILD
new file mode 100644
index 00000000..2175b900
--- /dev/null
+++ b/extra/python-urllib3/PKGBUILD
@@ -0,0 +1,18 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+
+ # disable sphinx for now, needs too many packages
+ makedepends=(${makedepends[@]//python2-sphinx/})
+
+ eval "$(
+ declare -f build | \
+ sed '
+ /make.*html/d
+ '
+ )"
+
+ pkgname=(${pkgname[@]//python-urllib3-doc})
+
+ unset check
+fi
diff --git a/extra/python/PKGBUILD b/extra/python/PKGBUILD
index 30e16fe8..407d9333 100644
--- a/extra/python/PKGBUILD
+++ b/extra/python/PKGBUILD
@@ -14,3 +14,29 @@ eval "$(
s/ -m test.regrtest/ -m test.regrtest -j1/
"
)"
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # remove dependency on most things, we want only a simple interpreter
+ # a little bit smarter than a shell for building and code generation
+ makedepends=(${makedepends[@]//tk/})
+ makedepends=(${makedepends[@]//bluez-libs/})
+ makedepends=(${makedepends[@]//llvm/})
+
+ # do not start X servers just for building software!
+ makedepends=(${makedepends[@]//xorg-server-xvfb/})
+ eval "$(
+ declare -f build | \
+ sed '
+ /export servernum=99/,/done/d
+ s/.*make/make/
+ '
+ )"
+ eval "$(
+ declare -f check | \
+ sed '
+ /export servernum=99/,/done/d
+ s/xvfb-run -s "-screen 0 1280x720x24 -ac +extension GLX" -a -n "$servernum"//
+ '
+ )"
+fi
diff --git a/extra/python2-ipaddress/PKGBUILD b/extra/python2-ipaddress/PKGBUILD
new file mode 100644
index 00000000..31dffbd8
--- /dev/null
+++ b/extra/python2-ipaddress/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pip-bootstrap' 'python2-pip-bootstrap')
+ unset check
+fi
diff --git a/extra/python2/PKGBUILD b/extra/python2/PKGBUILD
index c93cac57..8dea0a15 100644
--- a/extra/python2/PKGBUILD
+++ b/extra/python2/PKGBUILD
@@ -30,3 +30,38 @@ eval "$(
s/ -m test.regrtest/ -m test.regrtest -j1/
"
)"
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # remove dependency on most things, we want only a simple interpreter
+ # a little bit smarter than a shell for building and code generation
+ makedepends=(${makedepends[@]//tk/})
+ makedepends=(${makedepends[@]//bluez-libs/})
+ makedepends=(${makedepends[@]//llvm/})
+
+ # do not start X servers just for building software!
+ checkdepends=(${checkdepends[@]//xorg-server-xvfb/})
+ eval "$(
+ declare -f build | \
+ sed '
+ /export servernum=99/,/done/d
+ s/.*make/make/
+ '
+ )"
+ eval "$(
+ declare -f check | \
+ sed '
+ /export servernum=99/,/done/d
+ s/xvfb-run//
+ '
+ )"
+
+ # ignore even more tests
+ eval "$(
+ declare -f check | \
+ sed '
+ s/-v -uall -x/-v -uall -x test_gdb test_ssl test_urllib2net/
+ '
+ )"
+fi
+
diff --git a/extra/valgrind/PKGBUILD b/extra/valgrind/PKGBUILD
index 09f114cc..f927249d 100644
--- a/extra/valgrind/PKGBUILD
+++ b/extra/valgrind/PKGBUILD
@@ -4,3 +4,12 @@ replaces=("${replaces[@]/$pkgname-multilib}")
unset checkdepends
unset check
+
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # disable OpenMPI support
+ makedepends=(${makedepends[@]//openmpi/})
+
+ # no docbook
+ makedepends=(${makedepends[@]//docbook-sgml/})
+fi
diff --git a/extra/w3m/PKGBUILD b/extra/w3m/PKGBUILD
new file mode 100644
index 00000000..913d7e12
--- /dev/null
+++ b/extra/w3m/PKGBUILD
@@ -0,0 +1,5 @@
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no imlib2
+ makedepends=(${makedepends[@]//imlib2/})
+fi