summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/qt5-tools/PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/extra/qt5-tools/PKGBUILD b/extra/qt5-tools/PKGBUILD
index 02ccc2f5..f66fbf05 100644
--- a/extra/qt5-tools/PKGBUILD
+++ b/extra/qt5-tools/PKGBUILD
@@ -1,2 +1,8 @@
-# break cycle with qt5-webkit (icu68, icu69 mess-up)
-makedepends=(${makedepends[@]//qt5-webkit/})
+# break cycle on i486 with qt5-webkit
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//qt5-webkit/})
+fi
+
+# qt5-webkit is linked against icu68, icu 69 is current version
+# (breaking linkage)
+makedepends+=(icu68)