summaryrefslogtreecommitdiff
path: root/extra/qt5-base
diff options
context:
space:
mode:
Diffstat (limited to 'extra/qt5-base')
-rw-r--r--extra/qt5-base/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/qt5-base/PKGBUILD b/extra/qt5-base/PKGBUILD
index a5a0a8e6..b7db1fd6 100644
--- a/extra/qt5-base/PKGBUILD
+++ b/extra/qt5-base/PKGBUILD
@@ -17,3 +17,13 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# no LTO on 486 slaves, they die with out-of-memory
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/\(.*qmake *\)CONFIG+=fat-static-lto\(.*\)/\1 \2/
+ '
+ )"
+fi