summaryrefslogtreecommitdiff
path: root/extra/mutter/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/mutter/PKGBUILD')
-rw-r--r--extra/mutter/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/mutter/PKGBUILD b/extra/mutter/PKGBUILD
index 6375c77f..c18d7aae 100644
--- a/extra/mutter/PKGBUILD
+++ b/extra/mutter/PKGBUILD
@@ -5,3 +5,13 @@ eval "$(
s/\(meson test -C build\)/\1 || true/
'
)"
+
+source+=(fix-build.diff)
+sha256sum+=('28aa24daed161f2566ca2b159beb43285184c533956b851a7eb318de741da935')
+
+prepare() {
+ cd $pkgname
+
+ # fix build with libglvnd's EGL headers
+ git apply -3 ../fix-build.diff
+}