summaryrefslogtreecommitdiff
path: root/extra/mesa
diff options
context:
space:
mode:
Diffstat (limited to 'extra/mesa')
-rw-r--r--extra/mesa/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/mesa/PKGBUILD b/extra/mesa/PKGBUILD
index 1a4ca069..1a597eca 100644
--- a/extra/mesa/PKGBUILD
+++ b/extra/mesa/PKGBUILD
@@ -140,3 +140,13 @@ if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# LTO on i486 results in out-of-memory
+if [ "$CARCH" == 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-D b_lto=true/-D b_lto=false/
+ '
+ )"
+fi