summaryrefslogtreecommitdiff
path: root/extra/firefox
diff options
context:
space:
mode:
Diffstat (limited to 'extra/firefox')
-rw-r--r--extra/firefox/PKGBUILD3
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch29
2 files changed, 19 insertions, 13 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 46db9912..2ea1d935 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -91,10 +91,11 @@ eval "$(
# test failure in rust code (complaining about network functions) when PGO is used,
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums+=('3502138d1b43d734743137b97ea220d56338e7ee15d6159b030489637e274fc0')
+sha256sums+=('34eea882ba21a0ce641f352a200ede115a8d4befd16fe43303ba1d0aa7f90abd')
eval "$(
declare -f prepare | \
sed '
$ i patch -p1 -i "$srcdir/rust-static-disable-network-test-on-static-libraries.patch"
'
)"
+
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
index 84dcc1d3..9e4baffa 100644
--- a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -1,19 +1,24 @@
diff -rauN a/config/makefiles/rust.mk b/config/makefiles/rust.mk
---- a/config/makefiles/rust.mk 2019-09-21 12:17:00.399732877 +0200
-+++ b/config/makefiles/rust.mk 2019-09-21 12:18:04.531378287 +0200
-@@ -244,6 +244,7 @@
+--- a/config/makefiles/rust.mk 2019-09-17 19:02:50.000000000 +0200
++++ b/config/makefiles/rust.mk 2019-09-21 15:24:51.554451253 +0200
+@@ -244,13 +244,13 @@
# When we are building in --enable-release mode; we add an additional check to confirm
# that we are not importing any networking-related functions in rust code. This reduces
# the chance of proxy bypasses originating from rust code.
-+ifndef MOZ_PROFILE_GENERATE
- ifndef DEVELOPER_OPTIONS
- ifndef MOZ_DEBUG_RUST
- ifeq ($(OS_ARCH), Linux)
-@@ -251,6 +252,7 @@
- endif
- endif
- endif
-+endif
+-ifndef DEVELOPER_OPTIONS
+-ifndef MOZ_DEBUG_RUST
+-ifeq ($(OS_ARCH), Linux)
+- $(call py_action,check_binary,--target --networking $@)
+-endif
+-endif
+-endif
++#ifndef DEVELOPER_OPTIONS
++#ifndef MOZ_DEBUG_RUST
++#ifeq ($(OS_ARCH), Linux)
++# $(call py_action,check_binary,--target --networking $@)
++#endif
++#endif
++#endif
force-cargo-library-check:
$(call CARGO_CHECK) --lib $(cargo_target_flag) $(rust_features_flag)