summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/dbus/PKGBUILD13
-rw-r--r--core/ding-libs/PKGBUILD18
-rw-r--r--core/libsecret/PKGBUILD6
3 files changed, 7 insertions, 30 deletions
diff --git a/core/dbus/PKGBUILD b/core/dbus/PKGBUILD
index f2ad0e68..41a96d38 100644
--- a/core/dbus/PKGBUILD
+++ b/core/dbus/PKGBUILD
@@ -1,16 +1,5 @@
# i486-specific
if [ "${CARCH}" = "i486" ]; then
- # no documentation
- makedepends=(${makedepends[@]//docbook-xsl/})
- makedepends=(${makedepends[@]//yelp-tools/})
- makedepends=(${makedepends[@]//doxygen/})
+ # no graphviz generated graphs in documentation
makedepends=(${makedepends[@]//graphviz/})
-
- eval "$(
- declare -f build | \
- sed '
- s/configure/configure --disable-xml-docs --disable-doxygen-docs --disable-ducktype-docs/
- '
- )"
fi
-
diff --git a/core/ding-libs/PKGBUILD b/core/ding-libs/PKGBUILD
deleted file mode 100644
index 74f9000c..00000000
--- a/core/ding-libs/PKGBUILD
+++ /dev/null
@@ -1,18 +0,0 @@
-# already fixed upstream, see https://github.com/SSSD/ding-libs/issues/7
-
-source+=('ding-libs-0.6.1-ini_validators_ut_check-glibc-2.28.patch')
-sha1sums+=('bec66945c3524a9edf4956f794e99ca4d3d144e0')
-
-prepare() {
- cd $pkgname-$pkgver
-
- patch -Np1 -i ../ding-libs-0.6.1-ini_validators_ut_check-glibc-2.28.patch
-}
-
-# i486-specific
-if [ "${CARCH}" = "i486" ]; then
- # disable documentation
- makedepends=(${makedepends[@]//doxygen/})
-
- unset check
-fi
diff --git a/core/libsecret/PKGBUILD b/core/libsecret/PKGBUILD
new file mode 100644
index 00000000..d6231f62
--- /dev/null
+++ b/core/libsecret/PKGBUILD
@@ -0,0 +1,6 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no Vala
+ makedepends=(${makedepends[@]//vala/})
+fi
+