summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
Diffstat (limited to 'core')
-rw-r--r--core/autoconf/PKGBUILD18
-rw-r--r--core/autoconf/autoconf-2.69-go-test-351-OpenFile.patch21
-rw-r--r--core/automake/PKGBUILD5
-rw-r--r--core/glibc/PKGBUILD22
-rw-r--r--core/openssl/PKGBUILD11
-rw-r--r--core/pcre2/PKGBUILD13
6 files changed, 90 insertions, 0 deletions
diff --git a/core/autoconf/PKGBUILD b/core/autoconf/PKGBUILD
index 1957adf9..320aba12 100644
--- a/core/autoconf/PKGBUILD
+++ b/core/autoconf/PKGBUILD
@@ -6,3 +6,21 @@ if [ "${pkgname}-${pkgver}-${pkgrel}" = autoconf-2.69-4 ]; then
'
)"
fi
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # testing the go macros requires a running go actually
+ checkdepends+=('gcc-go')
+
+ # autoconf: 351 Go: https://lists.gnu.org/archive/html/bug-autoconf/2013-01/msg00000.html,
+ # see FS#57870 (closed upstream)
+ source+=('autoconf-2.69-go-test-351-OpenFile.patch')
+ md5sums+=('a7e1e05d4372b2ef5fae29b59e677e7d')
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /patch -p1.*libtool/ a \
+ patch -Np1 -i "${srcdir}/autoconf-2.69-go-test-351-OpenFile.patch"
+ '
+ )"
+fi
diff --git a/core/autoconf/autoconf-2.69-go-test-351-OpenFile.patch b/core/autoconf/autoconf-2.69-go-test-351-OpenFile.patch
new file mode 100644
index 00000000..b69f423d
--- /dev/null
+++ b/core/autoconf/autoconf-2.69-go-test-351-OpenFile.patch
@@ -0,0 +1,21 @@
+diff -rauN autoconf-2.69/lib/autoconf/go.m4 autoconf-2.69-go-test-351-OpenFile-patch/lib/autoconf/go.m4
+--- autoconf-2.69/lib/autoconf/go.m4 2012-01-21 14:46:39.000000000 +0100
++++ autoconf-2.69-go-test-351-OpenFile-patch/lib/autoconf/go.m4 2018-03-16 16:46:23.323273368 +0100
+@@ -61,7 +61,7 @@
+ # Produce source that performs I/O.
+ m4_define([_AC_LANG_IO_PROGRAM(Go)],
+ [AC_LANG_PROGRAM([import ( "fmt"; "os" )],
+-[f, err := os.Open("conftest.out", os.O_CREATE|os.O_WRONLY, 0777)
++[f, err := os.OpenFile("conftest.out", os.O_CREATE|os.O_WRONLY, 0777)
+ if err != nil {
+ fmt.Println(err)
+ os.Exit(1)
+@@ -107,7 +107,7 @@
+ "os"
+ )
+ ],
+-[f, err := os.Open("conftest.val", os.O_CREATE|os.O_WRONLY, 0777)
++[f, err := os.OpenFile("conftest.val", os.O_CREATE|os.O_WRONLY, 0777)
+ if err != nil {
+ os.Exit(1)
+ }
diff --git a/core/automake/PKGBUILD b/core/automake/PKGBUILD
new file mode 100644
index 00000000..af9256a9
--- /dev/null
+++ b/core/automake/PKGBUILD
@@ -0,0 +1,5 @@
+# 486-specific: we have no Vala or Java at the moment
+if [ "${CARCH}" = "i486" ]; then
+ checkdepends=(${checkdepends[@]//vala/})
+ checkdepends=(${checkdepends[@]//java-environment/})
+fi
diff --git a/core/glibc/PKGBUILD b/core/glibc/PKGBUILD
index 30370bd8..12033416 100644
--- a/core/glibc/PKGBUILD
+++ b/core/glibc/PKGBUILD
@@ -21,3 +21,25 @@ eval "$(
s,STRIP_STATIC ,\0usr/lib/libm.a ,
'
)"
+
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no gd for memory profiles
+ makedepends=(${makedepends[@]//gd/})
+
+ # disable multilib, we are on 32-bit only
+ eval "$(
+ declare -f build | \
+ sed '
+ s@--enable-multi-arch@--disable-multi-arch@
+ '
+ )"
+
+ # disable testing for now, we run out of memory
+ eval "$(
+ declare -f check | \
+ sed '
+ /make check/d
+ '
+ )"
+fi
diff --git a/core/openssl/PKGBUILD b/core/openssl/PKGBUILD
new file mode 100644
index 00000000..e3e0d088
--- /dev/null
+++ b/core/openssl/PKGBUILD
@@ -0,0 +1,11 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s@no-ssl3-method@no-ssl3-method no-ssl2 no-ssl3@
+ s@'i686'@'i486'@
+ s@'linux-elf'@'linux-generic32'@
+ '
+ )"
+fi
diff --git a/core/pcre2/PKGBUILD b/core/pcre2/PKGBUILD
new file mode 100644
index 00000000..da90f860
--- /dev/null
+++ b/core/pcre2/PKGBUILD
@@ -0,0 +1,13 @@
+# 486-specific: we have no Vala or Java at the moment
+if [ "${CARCH}" = "i486" ]; then
+ # pcre2 configure, overload CFLAGS and CXXFLAGS to avoid optimization
+ # using MMX registers (default in gcc)
+ # disable JIT, contains hard coded XMM registers
+ eval "$(
+ declare -f build | \
+ sed '
+ s@./configure@CFLAGS="-march=i486 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" CXXFLAGS="-march=i486 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" ./configure@
+ s/--enable-jit/--disable-jit/
+ '
+ )"
+fi