summaryrefslogtreecommitdiff
path: root/core/glibc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/glibc/PKGBUILD')
-rw-r--r--core/glibc/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/core/glibc/PKGBUILD b/core/glibc/PKGBUILD
index 30370bd8..83751716 100644
--- a/core/glibc/PKGBUILD
+++ b/core/glibc/PKGBUILD
@@ -21,3 +21,34 @@ eval "$(
s,STRIP_STATIC ,\0usr/lib/libm.a ,
'
)"
+
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no gd for memory profiles
+ makedepends=(${makedepends[@]//gd/})
+
+ # disable multilib, we are on 32-bit only
+ eval "$(
+ declare -f build | \
+ sed '
+ s@--enable-multi-arch@--disable-multi-arch@
+ '
+ )"
+
+ # disable testing for now, we run out of memory
+ eval "$(
+ declare -f check | \
+ sed '
+ /make check/d
+ '
+ )"
+
+ # disable CET (Control Flow instructions endbr32/enbr64)
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-cet/--disable-cet/
+ '
+ )"
+
+fi