summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/python-apipkg/PKGBUILD4
-rw-r--r--community/python-atomicwrites/PKGBUILD4
-rw-r--r--community/python-babel/PKGBUILD4
-rw-r--r--community/python-cachecontrol/PKGBUILD4
-rw-r--r--community/python-distlib/PKGBUILD5
-rw-r--r--community/python-distro/PKGBUILD30
-rw-r--r--community/python-html5lib/PKGBUILD4
-rw-r--r--community/python-iniconfig/PKGBUILD4
-rw-r--r--community/python-lockfile/PKGBUILD5
-rw-r--r--community/python-mock/PKGBUILD5
-rw-r--r--community/python-msgpack/PKGBUILD4
-rw-r--r--community/python-pbr/PKGBUILD4
-rw-r--r--community/python-pluggy/PKGBUILD4
-rw-r--r--community/python-py/PKGBUILD4
-rw-r--r--community/python-pytest/PKGBUILD5
-rw-r--r--community/python-setuptools-scm/PKGBUILD4
-rw-r--r--community/python-sqlalchemy/PKGBUILD4
-rw-r--r--community/python-webencodings/PKGBUILD4
-rw-r--r--community/python-whoosh/PKGBUILD4
-rw-r--r--community/python2-funcsigs/PKGBUILD4
20 files changed, 110 insertions, 0 deletions
diff --git a/community/python-apipkg/PKGBUILD b/community/python-apipkg/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-apipkg/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-atomicwrites/PKGBUILD b/community/python-atomicwrites/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-atomicwrites/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-babel/PKGBUILD b/community/python-babel/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-babel/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-cachecontrol/PKGBUILD b/community/python-cachecontrol/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-cachecontrol/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-distlib/PKGBUILD b/community/python-distlib/PKGBUILD
new file mode 100644
index 00000000..870e034f
--- /dev/null
+++ b/community/python-distlib/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # currently tests are failing, they are disabled not due to dependencies
+ unset check
+fi
diff --git a/community/python-distro/PKGBUILD b/community/python-distro/PKGBUILD
new file mode 100644
index 00000000..32d99307
--- /dev/null
+++ b/community/python-distro/PKGBUILD
@@ -0,0 +1,30 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # disable sphinx for now, needs too many packages
+ makedepends=(${makedepends[@]//python-sphinx/})
+ makedepends=(${makedepends[@]//python2-sphinx/})
+
+ eval "$(
+ declare -f build | \
+ sed '
+ s/make man SPHINXBUILD=sphinx-build2//
+ s/make man SPHINXBUILD=sphinx-build//
+ '
+ )"
+
+ eval "$(
+ declare -f package_python-distro | \
+ sed '
+ /install.*man.*ld.1/d
+ '
+ )"
+
+ eval "$(
+ declare -f package_python2-distro | \
+ sed '
+ /install.*man.*ld.1/d
+ '
+ )"
+
+ unset check
+fi
diff --git a/community/python-html5lib/PKGBUILD b/community/python-html5lib/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-html5lib/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-iniconfig/PKGBUILD b/community/python-iniconfig/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-iniconfig/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-lockfile/PKGBUILD b/community/python-lockfile/PKGBUILD
new file mode 100644
index 00000000..e50d2ff2
--- /dev/null
+++ b/community/python-lockfile/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pbr' 'python2-pbr')
+ unset check
+fi
diff --git a/community/python-mock/PKGBUILD b/community/python-mock/PKGBUILD
new file mode 100644
index 00000000..e50d2ff2
--- /dev/null
+++ b/community/python-mock/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-pbr' 'python2-pbr')
+ unset check
+fi
diff --git a/community/python-msgpack/PKGBUILD b/community/python-msgpack/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-msgpack/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-pbr/PKGBUILD b/community/python-pbr/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-pbr/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-pluggy/PKGBUILD b/community/python-pluggy/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-pluggy/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-py/PKGBUILD b/community/python-py/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-py/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-pytest/PKGBUILD b/community/python-pytest/PKGBUILD
new file mode 100644
index 00000000..6c63d86f
--- /dev/null
+++ b/community/python-pytest/PKGBUILD
@@ -0,0 +1,5 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ makedepends+=('python-setuptools-scm' 'python2-setuptools-scm')
+ unset check
+fi
diff --git a/community/python-setuptools-scm/PKGBUILD b/community/python-setuptools-scm/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-setuptools-scm/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-sqlalchemy/PKGBUILD b/community/python-sqlalchemy/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-sqlalchemy/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-webencodings/PKGBUILD b/community/python-webencodings/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-webencodings/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python-whoosh/PKGBUILD b/community/python-whoosh/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python-whoosh/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi
diff --git a/community/python2-funcsigs/PKGBUILD b/community/python2-funcsigs/PKGBUILD
new file mode 100644
index 00000000..ed73f8de
--- /dev/null
+++ b/community/python2-funcsigs/PKGBUILD
@@ -0,0 +1,4 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ unset check
+fi