summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/rust/PKGBUILD9
-rw-r--r--community/rust/config.toml.patch9
-rw-r--r--community/stratisd/PKGBUILD6
3 files changed, 24 insertions, 0 deletions
diff --git a/community/rust/PKGBUILD b/community/rust/PKGBUILD
new file mode 100644
index 00000000..221bfd43
--- /dev/null
+++ b/community/rust/PKGBUILD
@@ -0,0 +1,9 @@
+source+=(config.toml.patch)
+sha256sums+=('55d59786b6a24590951688c01910ac331996fc5ea5e20f10d227db24b93b1e74')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i patch -p1 -i "$srcdir/config.toml.patch"
+ '
+)"
diff --git a/community/rust/config.toml.patch b/community/rust/config.toml.patch
new file mode 100644
index 00000000..f479499b
--- /dev/null
+++ b/community/rust/config.toml.patch
@@ -0,0 +1,9 @@
+--- a/config.toml 2019-01-20 19:03:26.718067950 +0100
++++ b/config.toml 2019-01-20 19:03:52.614834201 +0100
+@@ -25,3 +25,6 @@
+
+ [target.x86_64-unknown-linux-gnu]
+ llvm-config = "/usr/bin/llvm-config"
++
++[target.i686-unknown-linux-gnu]
++llvm-config = "/usr/bin/llvm-config"
diff --git a/community/stratisd/PKGBUILD b/community/stratisd/PKGBUILD
new file mode 100644
index 00000000..b0518fe7
--- /dev/null
+++ b/community/stratisd/PKGBUILD
@@ -0,0 +1,6 @@
+eval "$(
+ declare -f build | \
+ sed '
+ 2 a export TARGET="${CARCH}-unknown-linux-gnu"
+ '
+)"