summaryrefslogtreecommitdiff
path: root/community/arrayfire/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/arrayfire/PKGBUILD')
-rw-r--r--community/arrayfire/PKGBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/community/arrayfire/PKGBUILD b/community/arrayfire/PKGBUILD
deleted file mode 100644
index bd3a63e3..00000000
--- a/community/arrayfire/PKGBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# modern cuda is no longer available for 32-bit
-makedepends=(${makedepends[@]//cuda/})
-
-# force 32-bit compilation
-eval "$(
- declare -f build | \
- sed '
- /^{/{
- a\
- export CFLAGS+=" -m32" \
- export CXXFLAGS+=" -m32"
- }
- '
-)"
-
-# compilation issues around dim_t casts, see https://github.com/arrayfire/arrayfire/issues/2161
-source+=(arrayfire-full-3.6.3-dim-cast.patch)
-sha512sums+=('717535d030973723e0f028dc7e86ccbe46c6661146cfe0fd2e26bef77d08f11af35e0971e53ad0d11ce23d5dca48f29247fb8cc2fce8a06d13c0e24d89e5ae2c')
-eval "$(
- declare -f prepare | \
- sed '
- /cd /a patch -Np1 -i ${srcdir}/arrayfire-full-3.6.3-dim-cast.patch
- '
-)"
-
-# no more CUDA support for 32-bit Linux
-source+=(arrayfire-full-3.6.0-no-cuda-backend-testing.patch)
-sha512sums+=('7c5912ecf59932a4c00f859190174b5b88f01010d131dfef4b013940543f157698d048297eb8c86e1d5289df8f7eb6d769fd39f069b7bf3262800ceca98d09fc')
-eval "$(
- declare -f prepare | \
- sed '
- /cd /a patch -Np1 -i ${srcdir}/arrayfire-full-3.6.0-no-cuda-backend-testing.patch
- '
-)"