summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--core/autoconf/PKGBUILD18
-rw-r--r--core/autoconf/autoconf-2.69-go-test-351-OpenFile.patch21
-rw-r--r--core/automake/PKGBUILD5
-rw-r--r--core/glibc/PKGBUILD22
-rw-r--r--core/openssl/PKGBUILD11
-rw-r--r--core/pcre2/PKGBUILD13
-rw-r--r--extra/git/PKGBUILD18
-rw-r--r--extra/jsoncpp/PKGBUILD18
-rw-r--r--extra/libuv/PKGBUILD17
-rw-r--r--extra/w3m/PKGBUILD5
10 files changed, 148 insertions, 0 deletions
diff --git a/core/autoconf/PKGBUILD b/core/autoconf/PKGBUILD
index 1957adf9..320aba12 100644
--- a/core/autoconf/PKGBUILD
+++ b/core/autoconf/PKGBUILD
@@ -6,3 +6,21 @@ if [ "${pkgname}-${pkgver}-${pkgrel}" = autoconf-2.69-4 ]; then
'
)"
fi
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # testing the go macros requires a running go actually
+ checkdepends+=('gcc-go')
+
+ # autoconf: 351 Go: https://lists.gnu.org/archive/html/bug-autoconf/2013-01/msg00000.html,
+ # see FS#57870 (closed upstream)
+ source+=('autoconf-2.69-go-test-351-OpenFile.patch')
+ md5sums+=('a7e1e05d4372b2ef5fae29b59e677e7d')
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /patch -p1.*libtool/ a \
+ patch -Np1 -i "${srcdir}/autoconf-2.69-go-test-351-OpenFile.patch"
+ '
+ )"
+fi
diff --git a/core/autoconf/autoconf-2.69-go-test-351-OpenFile.patch b/core/autoconf/autoconf-2.69-go-test-351-OpenFile.patch
new file mode 100644
index 00000000..b69f423d
--- /dev/null
+++ b/core/autoconf/autoconf-2.69-go-test-351-OpenFile.patch
@@ -0,0 +1,21 @@
+diff -rauN autoconf-2.69/lib/autoconf/go.m4 autoconf-2.69-go-test-351-OpenFile-patch/lib/autoconf/go.m4
+--- autoconf-2.69/lib/autoconf/go.m4 2012-01-21 14:46:39.000000000 +0100
++++ autoconf-2.69-go-test-351-OpenFile-patch/lib/autoconf/go.m4 2018-03-16 16:46:23.323273368 +0100
+@@ -61,7 +61,7 @@
+ # Produce source that performs I/O.
+ m4_define([_AC_LANG_IO_PROGRAM(Go)],
+ [AC_LANG_PROGRAM([import ( "fmt"; "os" )],
+-[f, err := os.Open("conftest.out", os.O_CREATE|os.O_WRONLY, 0777)
++[f, err := os.OpenFile("conftest.out", os.O_CREATE|os.O_WRONLY, 0777)
+ if err != nil {
+ fmt.Println(err)
+ os.Exit(1)
+@@ -107,7 +107,7 @@
+ "os"
+ )
+ ],
+-[f, err := os.Open("conftest.val", os.O_CREATE|os.O_WRONLY, 0777)
++[f, err := os.OpenFile("conftest.val", os.O_CREATE|os.O_WRONLY, 0777)
+ if err != nil {
+ os.Exit(1)
+ }
diff --git a/core/automake/PKGBUILD b/core/automake/PKGBUILD
new file mode 100644
index 00000000..af9256a9
--- /dev/null
+++ b/core/automake/PKGBUILD
@@ -0,0 +1,5 @@
+# 486-specific: we have no Vala or Java at the moment
+if [ "${CARCH}" = "i486" ]; then
+ checkdepends=(${checkdepends[@]//vala/})
+ checkdepends=(${checkdepends[@]//java-environment/})
+fi
diff --git a/core/glibc/PKGBUILD b/core/glibc/PKGBUILD
index 30370bd8..12033416 100644
--- a/core/glibc/PKGBUILD
+++ b/core/glibc/PKGBUILD
@@ -21,3 +21,25 @@ eval "$(
s,STRIP_STATIC ,\0usr/lib/libm.a ,
'
)"
+
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no gd for memory profiles
+ makedepends=(${makedepends[@]//gd/})
+
+ # disable multilib, we are on 32-bit only
+ eval "$(
+ declare -f build | \
+ sed '
+ s@--enable-multi-arch@--disable-multi-arch@
+ '
+ )"
+
+ # disable testing for now, we run out of memory
+ eval "$(
+ declare -f check | \
+ sed '
+ /make check/d
+ '
+ )"
+fi
diff --git a/core/openssl/PKGBUILD b/core/openssl/PKGBUILD
new file mode 100644
index 00000000..e3e0d088
--- /dev/null
+++ b/core/openssl/PKGBUILD
@@ -0,0 +1,11 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s@no-ssl3-method@no-ssl3-method no-ssl2 no-ssl3@
+ s@'i686'@'i486'@
+ s@'linux-elf'@'linux-generic32'@
+ '
+ )"
+fi
diff --git a/core/pcre2/PKGBUILD b/core/pcre2/PKGBUILD
new file mode 100644
index 00000000..da90f860
--- /dev/null
+++ b/core/pcre2/PKGBUILD
@@ -0,0 +1,13 @@
+# 486-specific: we have no Vala or Java at the moment
+if [ "${CARCH}" = "i486" ]; then
+ # pcre2 configure, overload CFLAGS and CXXFLAGS to avoid optimization
+ # using MMX registers (default in gcc)
+ # disable JIT, contains hard coded XMM registers
+ eval "$(
+ declare -f build | \
+ sed '
+ s@./configure@CFLAGS="-march=i486 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" CXXFLAGS="-march=i486 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" ./configure@
+ s/--enable-jit/--disable-jit/
+ '
+ )"
+fi
diff --git a/extra/git/PKGBUILD b/extra/git/PKGBUILD
new file mode 100644
index 00000000..d78c5181
--- /dev/null
+++ b/extra/git/PKGBUILD
@@ -0,0 +1,18 @@
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # we currently have no Gnome and libsecret, so disable integration
+ makedepends=(${makedepends[@]//libgnome-keyring/})
+ makedepends=(${makedepends[@]//libsecret/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s@\(make -C contrib/credential/gnome-keyring\)@#\1@
+ s@\(make -C contrib/credential/libsecret\)@#\1@
+ '
+ declare -f package | \
+ sed '
+ /gnome-keyring/d
+ /libsecret/d
+ '
+ )"
+fi
diff --git a/extra/jsoncpp/PKGBUILD b/extra/jsoncpp/PKGBUILD
new file mode 100644
index 00000000..a9b60ed8
--- /dev/null
+++ b/extra/jsoncpp/PKGBUILD
@@ -0,0 +1,18 @@
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no doxygen or graphviz
+ makedepends=(${makedepends[@]//doxygen/})
+ makedepends=(${makedepends[@]//graphviz/})
+ eval "$(
+ declare -f build | \
+ sed '
+ /python doxybuild.py/d
+ '
+ declare -f package_jsoncpp-doc | \
+ sed '
+ /cp -a dist\/doxygen/d
+ '
+ )"
+fi
+
+
diff --git a/extra/libuv/PKGBUILD b/extra/libuv/PKGBUILD
new file mode 100644
index 00000000..39ff340b
--- /dev/null
+++ b/extra/libuv/PKGBUILD
@@ -0,0 +1,17 @@
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no python sphinx
+ makedepends=(${makedepends[@]//python-sphinx/})
+ eval "$(
+ declare -f build | \
+ sed '
+ /make man/d
+ '
+ declare -f package | \
+ sed '
+ /install.*libuv/d
+ '
+ )"
+fi
+
+
diff --git a/extra/w3m/PKGBUILD b/extra/w3m/PKGBUILD
new file mode 100644
index 00000000..913d7e12
--- /dev/null
+++ b/extra/w3m/PKGBUILD
@@ -0,0 +1,5 @@
+# 486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no imlib2
+ makedepends=(${makedepends[@]//imlib2/})
+fi