summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--community/gdal/PKGBUILD4
-rw-r--r--extra/python-numpy/PKGBUILD17
2 files changed, 19 insertions, 2 deletions
diff --git a/community/gdal/PKGBUILD b/community/gdal/PKGBUILD
index f2c3ce89..e14cdc81 100644
--- a/community/gdal/PKGBUILD
+++ b/community/gdal/PKGBUILD
@@ -3,7 +3,7 @@ if [ "${CARCH}" = "i486" -o "${CARCH}" = "i686" ]; then
eval "$(
declare -f build | \
sed '
- s|./configure |./configure --with-sse=no --with-sse3-no --with-avx=no |
+ s|./configure |./configure --with-sse=no --with-ssse3=no --with-avx=no |
'
)"
fi
@@ -11,7 +11,7 @@ if [ "${CARCH}" = "pentium4" ]; then
eval "$(
declare -f build | \
sed '
- s|./configure |./configure --with-sse=yes --with-ssse3-no --with-avx=no |
+ s|./configure |./configure --with-sse=yes --with-ssse3=no --with-avx=no |
'
)"
fi
diff --git a/extra/python-numpy/PKGBUILD b/extra/python-numpy/PKGBUILD
new file mode 100644
index 00000000..6e15ddae
--- /dev/null
+++ b/extra/python-numpy/PKGBUILD
@@ -0,0 +1,17 @@
+# enable SSE/SSE2 on pentium4, no optimizations on i686 and i486
+if [ "${CARCH}" = "i486" -o "${CARCH}" = "i686" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|python setup.py build|python setup.py build --cpu-baseline=NONE --cpu-dispatch=NONE|
+ '
+ )"
+fi
+if [ "${CARCH}" = "pentium4" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|python setup.py build|python setup.py build --cpu-baseline=NONE --cpu-dispatch=SSE,SSE2|
+ '
+ )"
+fi