summaryrefslogtreecommitdiff
path: root/core
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:03:12 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:03:12 +0100
commit7f1e3da67e8b6bbc45c85937d4938547f32076d6 (patch)
treedbf618bb5edd9e0fd2cab1d629997f5885c2a3c3 /core
parent6b98f5a19f2f93f145e1e5b5d1e79d6ff29620fe (diff)
parent6d7fd11017d125970175ea85882920cc413e835e (diff)
downloadpackages-7f1e3da67e8b6bbc45c85937d4938547f32076d6.tar.xz
Merge branch 'master' into i486
Diffstat (limited to 'core')
-rw-r--r--core/libaio/PKGBUILD8
-rw-r--r--core/libaio/libaio-0.3.111-sizeof-template.patch24
-rw-r--r--core/libsecret/PKGBUILD3
-rw-r--r--core/syslinux/PKGBUILD12
-rw-r--r--core/syslinux/syslinux-strip-gnu-property.patch18
5 files changed, 65 insertions, 0 deletions
diff --git a/core/libaio/PKGBUILD b/core/libaio/PKGBUILD
index 92c69c31..a4cbd68f 100644
--- a/core/libaio/PKGBUILD
+++ b/core/libaio/PKGBUILD
@@ -7,3 +7,11 @@ eval "$(
s@make$@CFLAGS="-march=${CARCH/_/-} -mtune=generic -O2 -pipe -fno-stack-protector" make@
'
)"
+
+# see also FS#60283
+source+=('libaio-0.3.111-sizeof-template.patch')
+md5sums+=('8c240ea721460fa2d34f9e134b57544d')
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i ../libaio-0.3.111-sizeof-template.patch
+}
diff --git a/core/libaio/libaio-0.3.111-sizeof-template.patch b/core/libaio/libaio-0.3.111-sizeof-template.patch
new file mode 100644
index 00000000..5eee8958
--- /dev/null
+++ b/core/libaio/libaio-0.3.111-sizeof-template.patch
@@ -0,0 +1,24 @@
+diff -rauN libaio-0.3.111/harness/cases/19.t libaio-0.3.111-sizeof-template-patch/harness/cases/19.t
+--- libaio-0.3.111/harness/cases/19.t 2018-03-06 23:24:47.000000000 +0100
++++ libaio-0.3.111-sizeof-template-patch/harness/cases/19.t 2018-10-14 10:02:19.004873314 +0200
+@@ -41,7 +41,7 @@
+ int fd;
+ char template[sizeof(TEMPLATE)];
+
+- strncpy(template, TEMPLATE, sizeof(TEMPLATE));
++ strncpy(template, TEMPLATE, sizeof(template));
+ fd = mkostemp(template, O_DIRECT);
+ if (fd < 0) {
+ perror("mkstemp");
+diff -rauN libaio-0.3.111/harness/cases/21.t libaio-0.3.111-sizeof-template-patch/harness/cases/21.t
+--- libaio-0.3.111/harness/cases/21.t 2018-03-06 23:24:47.000000000 +0100
++++ libaio-0.3.111-sizeof-template-patch/harness/cases/21.t 2018-10-14 10:02:34.901333421 +0200
+@@ -43,7 +43,7 @@
+ int fd;
+ char temp_file[sizeof(TEMPLATE)];
+
+- strncpy(temp_file, TEMPLATE, sizeof(TEMPLATE));
++ strncpy(temp_file, TEMPLATE, sizeof(temp_file));
+ fd = mkstemp(temp_file);
+ if (fd < 0) {
+ perror("mkstemp");
diff --git a/core/libsecret/PKGBUILD b/core/libsecret/PKGBUILD
index d6231f62..d2a68fe8 100644
--- a/core/libsecret/PKGBUILD
+++ b/core/libsecret/PKGBUILD
@@ -2,5 +2,8 @@
if [ "${CARCH}" = "i486" ]; then
# no Vala
makedepends=(${makedepends[@]//vala/})
+
+ # no Gnome (gjs), no dbus-glib
+ unset check
fi
diff --git a/core/syslinux/PKGBUILD b/core/syslinux/PKGBUILD
index 410b180a..16d4f937 100644
--- a/core/syslinux/PKGBUILD
+++ b/core/syslinux/PKGBUILD
@@ -11,3 +11,15 @@ eval "$(
'
)"
+# binutils adds a nore.gnu.proprerty ELF section, this makes the MBR slightly
+# too big to fit on disk (see also https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=906414)
+
+source+=(syslinux-strip-gnu-property.patch)
+sha1sums+=('fb8e96b559516038e628ad55e0331e4c668205a8')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /patch.*efi_no_kbd/a patch -p1 < ../syslinux-strip-gnu-property.patch
+ '
+)"
diff --git a/core/syslinux/syslinux-strip-gnu-property.patch b/core/syslinux/syslinux-strip-gnu-property.patch
new file mode 100644
index 00000000..363a1ee2
--- /dev/null
+++ b/core/syslinux/syslinux-strip-gnu-property.patch
@@ -0,0 +1,18 @@
+diff -rauN syslinux/mbr/i386/mbr.ld syslinux-strip-gnu-property-patch/mbr/i386/mbr.ld
+--- syslinux/mbr/i386/mbr.ld 2018-10-14 13:54:59.532050409 +0200
++++ syslinux-strip-gnu-property-patch/mbr/i386/mbr.ld 2018-10-14 14:06:48.788976484 +0200
+@@ -70,4 +70,5 @@
+ .debug_typenames 0 : { *(.debug_typenames) }
+ .debug_varnames 0 : { *(.debug_varnames) }
+ /DISCARD/ : { *(.note.GNU-stack) }
++ /DISCARD/ : { *(.note.gnu.property) }
+ }
+diff -rauN syslinux/mbr/x86_64/mbr.ld syslinux-strip-gnu-property-patch/mbr/x86_64/mbr.ld
+--- syslinux/mbr/x86_64/mbr.ld 2018-10-14 13:54:59.533050375 +0200
++++ syslinux-strip-gnu-property-patch/mbr/x86_64/mbr.ld 2018-10-14 14:06:40.133269711 +0200
+@@ -69,4 +69,5 @@
+ .debug_typenames 0 : { *(.debug_typenames) }
+ .debug_varnames 0 : { *(.debug_varnames) }
+ /DISCARD/ : { *(.note.GNU-stack) }
++ /DISCARD/ : { *(.note.gnu.property) }
+ }