summaryrefslogtreecommitdiff
path: root/test/scripts/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/scripts/meson.build')
-rw-r--r--test/scripts/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/test/scripts/meson.build b/test/scripts/meson.build
new file mode 100644
index 00000000..0bdbfb2f
--- /dev/null
+++ b/test/scripts/meson.build
@@ -0,0 +1,15 @@
+tests = [
+ 'parseopts_test.sh',
+ 'makepkg-template_test.sh',
+ 'human_to_size_test.sh',
+]
+
+foreach tst : tests
+ test(tst,
+ PYTHON,
+ env : TEST_ENV,
+ args : [
+ join_paths(meson.source_root(), 'build-aux/tap-driver.py'),
+ join_paths(meson.current_source_dir(), tst),
+ ])
+endforeach