summaryrefslogtreecommitdiff
path: root/doc/PKGBUILD.5.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/PKGBUILD.5.txt')
-rw-r--r--doc/PKGBUILD.5.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/doc/PKGBUILD.5.txt b/doc/PKGBUILD.5.txt
index 83cebcdb..28dd8c7c 100644
--- a/doc/PKGBUILD.5.txt
+++ b/doc/PKGBUILD.5.txt
@@ -79,6 +79,12 @@ similar to `$_basekernver`.
be copied into the package by makepkg. It does not need to be included
in the source array (e.g. `install=pkgname.install`).
+*changelog*::
+ Specifies a changelog file that is to be included in the package.
+ This file should reside in the same directory as the PKGBUILD, and will
+ be copied into the package by makepkg. It does not need to be included
+ in the source array (e.g. `changelog=$pkgname.changelog`).
+
*source (array)*::
An array of source files required to build the package. Source files
must either reside in the same directory as the PKGBUILD file, or be a
@@ -145,7 +151,7 @@ name. The syntax is: `source=('filename::url')`.
base functionality, but may be necessary to make full use of the contents
of this package. optdepends are currently for informational purposes only
and are not utilized by pacman during dependency resolution. The format
- should be similar to the following:
+ for specifying optdepends is:
optdepends=('fakeroot: for makepkg usage as normal user')
@@ -269,9 +275,9 @@ name of the split package.
All options and directives for the split packages default to the global values given
within the PKGBUILD. However, some of these can be overridden within each split
-package's packaging function. The following variables can be overridden: `pkgdesc`,
-`license`, `groups`, `depends`, `optdepends`, `provides`, `conflicts`, `replaces`,
-`backup`, `options` and `install`.
+package's packaging function. The following variables can be overridden: `pkgver`,
+`pkgrel`, `pkgdesc`, `arch`, `license`, `groups`, `depends`, `optdepends`,
+`provides`, `conflicts`, `replaces`, `backup`, `options`, `install` and `changelog`.
An optional global directive is available when building a split package: