summaryrefslogtreecommitdiff
path: root/doc/PKGBUILD-example.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/PKGBUILD-example.txt')
-rw-r--r--doc/PKGBUILD-example.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/doc/PKGBUILD-example.txt b/doc/PKGBUILD-example.txt
new file mode 100644
index 00000000..2cc53808
--- /dev/null
+++ b/doc/PKGBUILD-example.txt
@@ -0,0 +1,20 @@
+# Maintainer: judd <jvinet@zeroflux.org>
+
+pkgname=patch
+pkgver=2.5.4
+pkgrel=3
+pkgdesc="A utility to apply patch files to original sources"
+arch=(i686 x86_64)
+url="http://www.gnu.org/software/patch/patch.html"
+license=('GPL')
+groups=('base-devel')
+depends=('glibc' 'ed')
+source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('ee5ae84d115f051d87fcaaef3b4ae782')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make prefix=$startdir/pkg/usr install
+}