summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@parabola.nu>2018-08-09 13:41:12 -0400
committerAllan McRae <allan@archlinux.org>2019-01-10 17:00:03 +1000
commitf7efa6a93d5361af610827d41045d87c7a72f2b5 (patch)
tree1d3d0bb731e5af544fa732b342fb95adecaee67e /scripts/Makefile.am
parent30e3e21e873b01b98ab91dc1252d4112d6a9fd2a (diff)
downloadpacman-f7efa6a93d5361af610827d41045d87c7a72f2b5.tar.xz
makepkg: Better error messages for versions in (check, make, opt)depends/provides/conflicts
Given the depends depends=('foo>=1.2-1.par2') and the error message ==> ERROR: pkgver in depends is not allowed to contain colons, forward slashes, hyphens or whitespace. One would be lead to believe that the problem is that they gave a pkgrel in depends at all, not that the pkgrel contains letters. Each of the (check,make,opt)depends, conflicts, and provides linters use a glob to trim off properly formed epoch an rel from the full version string, and pass the remainder to check_pkgver(). This does a good job of accepting/rejecting full versions, but doesn't do a good job of generating good error messages when rejecting if it's because of the epoch or rel. 1. Factor out check_epoch() and check_pkgrel() from lint_epoch() and lint_pkgrel(), similarly to check_pkgver(). 2. Add a check_fullpkgver() that takes a full [epoch:]ver[-rel] string and splits it in to epoch/ver/rel, and calls the appropriate check_ function on each. 3. Use check_fullpkgver() in the {,check,make,opt}depends, conflicts, and provides linters. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 54a8d215..4bb79b05 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -85,6 +85,7 @@ LIBMAKEPKG_IN = \
libmakepkg/lint_pkgbuild/conflicts.sh \
libmakepkg/lint_pkgbuild/depends.sh \
libmakepkg/lint_pkgbuild/epoch.sh \
+ libmakepkg/lint_pkgbuild/fullpkgver.sh \
libmakepkg/lint_pkgbuild/install.sh \
libmakepkg/lint_pkgbuild/makedepends.sh \
libmakepkg/lint_pkgbuild/optdepends.sh \