summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2019-01-10 00:58:41 -0500
committerAllan McRae <allan@archlinux.org>2019-01-10 17:01:30 +1000
commit031611ff40bb85e493453913ae808116fa92c3cc (patch)
tree8174ec4f5960db63aa16b240a17fbdb4cee55148 /scripts/Makefile.am
parent10fe71e5f3ed5cff52166e78ca063baf8d1c1b83 (diff)
downloadpacman-031611ff40bb85e493453913ae808116fa92c3cc.tar.xz
libmakepkg: add routine for linting $SOURCE_DATE_EPOCH
This can only ever be an int, and the specification states that a malformed timestamp should be considered a fatal error. https://reproducible-builds.org/specs/source-date-epoch/ Signed-off-by: Eli Schwartz <eschwartz@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 4bb79b05..08fc34b2 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -71,6 +71,7 @@ LIBMAKEPKG_IN = \
libmakepkg/integrity/verify_signature.sh \
libmakepkg/lint_config.sh \
libmakepkg/lint_config/paths.sh \
+ libmakepkg/lint_config/source_date_epoch.sh \
libmakepkg/lint_config/variable.sh \
libmakepkg/lint_package.sh \
libmakepkg/lint_package/build_references.sh \