summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/openal/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/extra/openal/PKGBUILD b/extra/openal/PKGBUILD
new file mode 100644
index 00000000..6c8ed3c2
--- /dev/null
+++ b/extra/openal/PKGBUILD
@@ -0,0 +1,22 @@
+if [ "$CARCH" = 'pentium4' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s@cmake@cmake -DALSOFT_CPUEXT_SSE3=0 -DALSOFT_CPUEXT_SSE4_1=0@
+ '
+ )"
+elif [ "$CARCH" = 'i686' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s@cmake@cmake -DALSOFT_ENABLE_SSE2_CODEGEN=0 -DALSOFT_CPUEXT_SSE2=0@
+ '
+ )"
+elif [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s@cmake@cmake -DALSOFT_CPUEXT_SSE=0 -DALSOFT_ENABLE_SSE_CODEGEN=0 -DALSOFT_ENABLE_SSE2_CODEGEN=0@
+ '
+ )"
+fi