summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/python/PKGBUILD13
-rw-r--r--extra/python2/PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/extra/python/PKGBUILD b/extra/python/PKGBUILD
new file mode 100644
index 00000000..53a0513b
--- /dev/null
+++ b/extra/python/PKGBUILD
@@ -0,0 +1,13 @@
+eval "$(
+ declare -f build | \
+ sed "
+ s/make /make EXTRATESTOPTS='-j 1' /
+ "
+)"
+
+eval "$(
+ declare -f check | \
+ sed "
+ s/ -m test.regrtest/ -m test.regrtest -j1/
+ "
+)"
diff --git a/extra/python2/PKGBUILD b/extra/python2/PKGBUILD
index 7ff6b97e..c93cac57 100644
--- a/extra/python2/PKGBUILD
+++ b/extra/python2/PKGBUILD
@@ -13,3 +13,20 @@ eval "$(
/xvfb-run/ s/-x test_idle/-x test_idle test_bytes test_str test_string test_unicode test_userstring test_tuple/
'
)"
+
+# tests run with -j4 per default effectively killing build slaves,
+# forcing single threaded execution of tests
+
+eval "$(
+ declare -f build | \
+ sed "
+ s/make/make EXTRATESTOPTS='-j 1' /
+ "
+)"
+
+eval "$(
+ declare -f check | \
+ sed "
+ s/ -m test.regrtest/ -m test.regrtest -j1/
+ "
+)"