summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/llvm/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/extra/llvm/PKGBUILD b/extra/llvm/PKGBUILD
new file mode 100644
index 00000000..4aaafe29
--- /dev/null
+++ b/extra/llvm/PKGBUILD
@@ -0,0 +1,19 @@
+# temporary, ocaml is broken on 32-bit, we work around the llvm issue
+# in binutils LTO plugins for now:
+makedepends=(${makedepends[@]/ocaml=$_ocaml_ver/})
+makedepends=(${makedepends[@]/ocaml-ctypes/})
+makedepends=(${makedepends[@]/ocaml-findlib/})
+
+eval "$(
+ declare -f build | \
+ sed '
+ s/ninja all ocaml_doc/ninja all/
+ '
+)"
+
+eval "$(
+ declare -f package_llvm | \
+ sed '
+ /ocaml/d
+ '
+)"