summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/libxkbcommon/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/extra/libxkbcommon/PKGBUILD b/extra/libxkbcommon/PKGBUILD
index 1c545368..3c04600f 100644
--- a/extra/libxkbcommon/PKGBUILD
+++ b/extra/libxkbcommon/PKGBUILD
@@ -40,6 +40,19 @@ if [ "${CARCH}" = "i486" ]; then
s/arch-meson/arch-meson -Denable-x11=false/
'
)"
+
+ pkgname=($(
+ printf '%s\n' "${pkgname[@]}" | \
+ sed '/^libxkbcommon-x11/d'
+ ))
+
+ eval "$(
+ declare -f package_libxkbcommon | \
+ sed '
+ /x11/d
+ '
+ )"
+
fi