summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/python/PKGBUILD17
-rw-r--r--extra/python2/PKGBUILD17
2 files changed, 34 insertions, 0 deletions
diff --git a/extra/python/PKGBUILD b/extra/python/PKGBUILD
index 380fd779..407d9333 100644
--- a/extra/python/PKGBUILD
+++ b/extra/python/PKGBUILD
@@ -1,3 +1,20 @@
+# tests run with -j4 per default effectively killing build slaves,
+# forcing single threaded execution of tests
+
+eval "$(
+ declare -f build | \
+ sed "
+ s/make /make EXTRATESTOPTS='-j 1' /
+ "
+)"
+
+eval "$(
+ declare -f check | \
+ sed "
+ s/ -m test.regrtest/ -m test.regrtest -j1/
+ "
+)"
+
# i486-specific
if [ "${CARCH}" = "i486" ]; then
# remove dependency on most things, we want only a simple interpreter
diff --git a/extra/python2/PKGBUILD b/extra/python2/PKGBUILD
index 65e8d592..8dea0a15 100644
--- a/extra/python2/PKGBUILD
+++ b/extra/python2/PKGBUILD
@@ -14,6 +14,23 @@ eval "$(
'
)"
+# tests run with -j4 per default effectively killing build slaves,
+# forcing single threaded execution of tests
+
+eval "$(
+ declare -f build | \
+ sed "
+ s/make/make EXTRATESTOPTS='-j 1' /
+ "
+)"
+
+eval "$(
+ declare -f check | \
+ sed "
+ s/ -m test.regrtest/ -m test.regrtest -j1/
+ "
+)"
+
# i486-specific
if [ "${CARCH}" = "i486" ]; then
# remove dependency on most things, we want only a simple interpreter