summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/thunderbird/PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/extra/thunderbird/PKGBUILD b/extra/thunderbird/PKGBUILD
index 6fa9a0ea..8008522a 100644
--- a/extra/thunderbird/PKGBUILD
+++ b/extra/thunderbird/PKGBUILD
@@ -1,23 +1,28 @@
eval "$(
- declare -f build | \
- sed '
- /cd mozilla-unified/a sed -i "s/\\(cargo_rustc_flags += -C lto\\)/#\\1/" config/rules.mk
- '
declare -f prepare | \
sed '
+ /sed/ a \
+ sed -i "s/ac_add_options --enable-linker=gold/ac_add_options --enable-linker=bfd/" .mozconfig
$ i LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
- s/ac_add_options --enable-linker=gold/ac_add_options --enable-linker=bfd/
'
)"
+# no longer applies (TODO: check where we can set this)
+#~ eval "$(
+ #~ declare -f build | \
+ #~ sed '
+ #~ /cd mozilla-unified/a sed -i "s/\\(cargo_rustc_flags += -C lto\\)/#\\1/" config/rules.mk
+ #~ '
+#~ )"
+
# from VoidLinux, avoid excessive debug symbols in rust leading
# to out-of-memory situations
-eval "$(
- declare -f build | \
- sed '
- 4 a sed -i "s/debug_info = '\''2'\''/debug_info = '\''1'\''/" build/moz.configure/toolchain.configure
- '
-)"
+#~ eval "$(
+ #~ declare -f build | \
+ #~ sed '
+ #~ 2 a sed -i "s/debug_info = '\''2'\''/debug_info = '\''1'\''/" build/moz.configure/toolchain.configure
+ #~ '
+#~ )"
# don't kill build slaves by auto-guessing available CPU cores
eval "$(