summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/linux-zen/PKGBUILD6
-rw-r--r--extra/linux-zen/config5
2 files changed, 7 insertions, 4 deletions
diff --git a/extra/linux-zen/PKGBUILD b/extra/linux-zen/PKGBUILD
index 878620af..7b45b5fb 100644
--- a/extra/linux-zen/PKGBUILD
+++ b/extra/linux-zen/PKGBUILD
@@ -1,9 +1,9 @@
-# upstream git revision: d018e2ef20478136bb036d03affea692b02e6a4f
+# upstream git revision: e2dad31f767e935c33f0bdc30f3ca9e02eff10b3
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = '26539413aaf3f39a9e576abdc771eaa4e074e94ba4460103822e7bfbe6685fbd' ]; then
- sha256sums[${i}]='cbb73ce3df06197228c3c076a97c4ba84ec7381ed2d6fa302ee824b780717686'
+ if [ "${sha256sums[${i}]}" = 'a37511ef27ad2600d9d2f01b452cf2c78a4da7a8ffe728e28545707600c8e6c7' ]; then
+ sha256sums[${i}]='a1d9b5724b009c04c44374fda40de357777ebf0f68b15dbe4047f49d1885e087'
fi
done
diff --git a/extra/linux-zen/config b/extra/linux-zen/config
index 960e53cb..c7dcbba6 100644
--- a/extra/linux-zen/config
+++ b/extra/linux-zen/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.3.10-zen1 Kernel Configuration
+# Linux/x86 5.3.11-zen1 Kernel Configuration
#
#
@@ -469,6 +469,9 @@ CONFIG_ARCH_USES_PG_UNCACHED=y
CONFIG_ARCH_RANDOM=y
CONFIG_X86_SMAP=y
CONFIG_X86_INTEL_UMIP=y
+# CONFIG_X86_INTEL_TSX_MODE_OFF is not set
+# CONFIG_X86_INTEL_TSX_MODE_ON is not set
+CONFIG_X86_INTEL_TSX_MODE_AUTO=y
CONFIG_EFI=y
CONFIG_EFI_STUB=y
CONFIG_SECCOMP=y