summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/libxkbcommon/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/extra/libxkbcommon/PKGBUILD b/extra/libxkbcommon/PKGBUILD
index a95d49b7..1c545368 100644
--- a/extra/libxkbcommon/PKGBUILD
+++ b/extra/libxkbcommon/PKGBUILD
@@ -28,5 +28,18 @@ if [ "${CARCH}" = "i486" ]; then
/mv.*doc/d
'
)"
+
+ # uses MESA, xorg-xcb
+ unset check
+ unset checkdepends
+
+ # disable X11 during bootstrapping
+ eval "$(
+ declare -f build | \
+ sed '
+ s/arch-meson/arch-meson -Denable-x11=false/
+ '
+ )"
+
fi