summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/firefox/PKGBUILD8
-rw-r--r--extra/firefox/avoid-libxul-OOM-python-check.patch8
-rw-r--r--extra/firefox/mozconfig.patch10
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch16
4 files changed, 20 insertions, 22 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index 34212cde..6a2bd9ff 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -2,7 +2,7 @@
# don't compile with clang, use gcc toolchain (clang has issues on IA32)
# TODO: document the rest..
source+=('mozconfig.patch')
-sha256sums+=('62eb5b45f7eaa1879f9c9b0df92ed8de869a25b05ef6cd71c699cb44cee7cc97')
+sha256sums+=('0dcc5435b83e39f5725850818494617f2098d7535619ee169237d450489d6260')
eval "$(
declare -f build | \
sed '
@@ -12,7 +12,7 @@ eval "$(
declare -f prepare | \
sed '
$ i export MOZ_SOURCE_CHANGESET="DEVEDITION_${pkgver//./_}_RELEASE"
- $ i patch -p1 -i "$srcdir/mozconfig.patch"
+ $ i patch -d .. -Np1 -i "$srcdir/mozconfig.patch"
'
)"
@@ -96,7 +96,7 @@ eval "$(
# test failure in rust code (complaining about network functions) when PGO is used,
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums+=('34eea882ba21a0ce641f352a200ede115a8d4befd16fe43303ba1d0aa7f90abd')
+sha256sums+=('d07e283d5c784bb44dcd0ad3f6b82f19cac562451ce07033e8dde50bf8c75d76')
eval "$(
declare -f prepare | \
sed '
@@ -106,7 +106,7 @@ eval "$(
# readelf: Error: Unable to seek to 0x801db328 for section headers
source+=('avoid-libxul-OOM-python-check.patch')
-sha256sums+=('00b7019218d015a11670d566bff6d62872357c29ee7f9ef4d29a7f63c46227b6')
+sha256sums+=('5a3e038a57c4576dcb88766d41cbfda5ad109d5cfe41d2000f7ba25563bf00f2')
eval "$(
declare -f prepare | \
sed '
diff --git a/extra/firefox/avoid-libxul-OOM-python-check.patch b/extra/firefox/avoid-libxul-OOM-python-check.patch
index d9db28ab..9ab81bb7 100644
--- a/extra/firefox/avoid-libxul-OOM-python-check.patch
+++ b/extra/firefox/avoid-libxul-OOM-python-check.patch
@@ -1,10 +1,10 @@
diff -rauN a/config/rules.mk b/config/rules.mk
---- a/config/rules.mk 2019-09-21 19:14:10.531026841 +0200
-+++ b/config/rules.mk 2019-09-21 19:15:08.752873377 +0200
-@@ -660,7 +660,7 @@
+--- a/config/rules.mk 2019-10-25 11:08:20.757231756 +0200
++++ b/config/rules.mk 2019-10-25 11:11:04.972821611 +0200
+@@ -663,7 +663,7 @@
$(RM) $@
endif
- $(MKSHLIB) $($@_$(OBJS_VAR_SUFFIX)) $(RESFILE) $(LDFLAGS) $(STATIC_LIBS) $(RUST_STATIC_LIB) $(SHARED_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS)
+ $(MKSHLIB) $($@_$(OBJS_VAR_SUFFIX)) $(RESFILE) $(LDFLAGS) $(STATIC_LIBS) $(SHARED_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS)
- $(call py_action,check_binary,--target $@)
+# $(call py_action,check_binary,--target $@)
diff --git a/extra/firefox/mozconfig.patch b/extra/firefox/mozconfig.patch
index 9e5d85de..88ebc50b 100644
--- a/extra/firefox/mozconfig.patch
+++ b/extra/firefox/mozconfig.patch
@@ -1,7 +1,7 @@
-diff -rauN a/.mozconfig b/.mozconfig
---- a/.mozconfig 2019-10-24 17:22:00.620041647 +0200
-+++ b/.mozconfig 2019-10-24 17:27:57.878744247 +0200
-@@ -5,11 +5,14 @@
+diff -rauN a/mozconfig b/mozconfig
+--- a/mozconfig 2019-10-25 10:25:41.779286572 +0200
++++ b/mozconfig 2019-10-25 10:31:23.717054770 +0200
+@@ -5,11 +5,12 @@
ac_add_options --enable-hardening
ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
@@ -16,8 +16,6 @@ diff -rauN a/.mozconfig b/.mozconfig
+export AR=gcc-ar
+export NM=gcc-nm
+export RANLIB=gcc-ranlib
-+
-++ac_add_options --disable-lto
# Branding
ac_add_options --enable-official-branding
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
index 9e4baffa..32dabb4c 100644
--- a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -1,20 +1,20 @@
diff -rauN a/config/makefiles/rust.mk b/config/makefiles/rust.mk
---- a/config/makefiles/rust.mk 2019-09-17 19:02:50.000000000 +0200
-+++ b/config/makefiles/rust.mk 2019-09-21 15:24:51.554451253 +0200
-@@ -244,13 +244,13 @@
- # When we are building in --enable-release mode; we add an additional check to confirm
+--- a/config/makefiles/rust.mk 2019-10-25 10:57:20.061421120 +0200
++++ b/config/makefiles/rust.mk 2019-10-25 11:06:30.065708309 +0200
+@@ -252,13 +252,13 @@
# that we are not importing any networking-related functions in rust code. This reduces
# the chance of proxy bypasses originating from rust code.
--ifndef DEVELOPER_OPTIONS
--ifndef MOZ_DEBUG_RUST
+ # The check only works when rust code is built with -Clto.
+-ifndef MOZ_PROFILE_GENERATE
-ifeq ($(OS_ARCH), Linux)
+-ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
- $(call py_action,check_binary,--target --networking $@)
-endif
-endif
-endif
-+#ifndef DEVELOPER_OPTIONS
-+#ifndef MOZ_DEBUG_RUST
++#ifndef MOZ_PROFILE_GENERATE
+#ifeq ($(OS_ARCH), Linux)
++#ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
+# $(call py_action,check_binary,--target --networking $@)
+#endif
+#endif