summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/archiso/PKGBUILD6
-rw-r--r--extra/linux-pae/PKGBUILD15
-rw-r--r--extra/linux-pae/config2
-rw-r--r--extra/linux-zen/PKGBUILD8
-rw-r--r--extra/linux-zen/config2
-rw-r--r--extra/nvidia-390xx-lts/PKGBUILD2
-rw-r--r--extra/nvidia-390xx-utils/PKGBUILD2
-rw-r--r--extra/nvidia-390xx/PKGBUILD2
8 files changed, 16 insertions, 23 deletions
diff --git a/extra/archiso/PKGBUILD b/extra/archiso/PKGBUILD
index 9ff3f3e6..e28be616 100644
--- a/extra/archiso/PKGBUILD
+++ b/extra/archiso/PKGBUILD
@@ -4,10 +4,8 @@ license=('GPL')
url='https://git.archlinux32.org/archlinux32/archiso32'
source=("https://sources.archlinux32.org/sources/${pkgname}32-i686-v${pkgver}.tar.gz"{,.sig})
unset sha256sums
-sha512sums=(
- 'ee6f912c09009f42389bf9eaea97a3e3c59122f20c2a62edbf57430f48777fc97d1b16853a4b08d5fa4c554804e2f27adbebdca2f55c2396ac45079c430ac144'
- 'SKIP'
-)
+sha512sums=('2588034a867d0dcc2b9b464afe1082f693e3b1addd4629ab76dce70b99871ef4ae865c37d8cbbdc303ba948b08d197b8539514f3a1774fb7af35c265c2826e67'
+ 'SKIP')
validpgpkeys=('DE9F7688CACF04FEB81A6C590AEEC90755DA7B5A')
eval "$(
diff --git a/extra/linux-pae/PKGBUILD b/extra/linux-pae/PKGBUILD
index 28904b14..10a3d18b 100644
--- a/extra/linux-pae/PKGBUILD
+++ b/extra/linux-pae/PKGBUILD
@@ -4,8 +4,8 @@
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgbase=linux-pae # Build stock -ARCH kernel
-_srcname=linux-4.17
-pkgver=4.17.10
+pkgver=4.17.12
+_srcname=linux-${pkgver}
pkgrel=1
arch=('i686')
url="https://www.kernel.org/"
@@ -14,7 +14,6 @@ makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
source=(
https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.{xz,sign}
- https://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.{xz,sign}
config # the main kernel config file
60-linux.hook # pacman hook for depmod
90-linux.hook # pacman hook for initramfs regeneration
@@ -24,14 +23,11 @@ source=(
0003-ACPI-watchdog-Prefer-iTCO_wdt-always-when-WDAT-table.patch
)
validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('9faa1dd896eaea961dc6e886697c0b3301277102e5bc976b2758f9a62d3ccd13'
+sha256sums=('c098e2e4dcb64f8e3fb5cec35e872ff383edefa18532744ddf35bbba829cb5a3'
'SKIP'
- '41ad005296c7a1b5245a87881f666b3f4d7aa05a6b9409454b2e473d473c4cee'
- 'SKIP'
- '6eb872aa69991b1f700d533ec8b092be60d4c8203e1cb7da4d42d167337ec2ac'
+ '83846fdaa0560d6078aa6c88bd23b7912435d07096016d830601d903d36bada2'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
@@ -45,9 +41,6 @@ _kernelname=${pkgbase#linux}
prepare() {
cd ${_srcname}
- # add upstream patch
- patch -p1 -i ../patch-${pkgver}
-
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
diff --git a/extra/linux-pae/config b/extra/linux-pae/config
index a4febc4e..f208df98 100644
--- a/extra/linux-pae/config
+++ b/extra/linux-pae/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.17.10-1 Kernel Configuration
+# Linux/x86 4.17.12-1 Kernel Configuration
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
diff --git a/extra/linux-zen/PKGBUILD b/extra/linux-zen/PKGBUILD
index a953a8b6..f5535bf0 100644
--- a/extra/linux-zen/PKGBUILD
+++ b/extra/linux-zen/PKGBUILD
@@ -1,9 +1,11 @@
# upstream git revision: d299e4f0ee4303f6184169b7c55c2fbf54d158f2
# fail if upstream's .config changes
-if [ "${sha256sums[6]}" = '02684ffee3ee036bc7b5362e413dd04fe7dcaed307f9dbd36e3b1f8fc6f05d54' ]; then
- sha256sums[6]='17d551876b9a7597f3e3a77bfe88c7b8b6df1b2ec3e50112879899075e38b27c'
-fi
+for ((i=0; i<${#sha256sums[@]}; i++)); do
+ if [ "${sha256sums[${i}]}" = '10e611499fb794178bb4b04a1869443e43f9f29e72741b6c19a304337802a7b1' ]; then
+ sha256sums[${i}]='af4b99815fb803bc92d35282609037adb6c6aebe079ad84a69b10aba60b53ddc'
+ fi
+done
eval "$(
declare -f package_linux-zen-headers | \
diff --git a/extra/linux-zen/config b/extra/linux-zen/config
index 7ef4698b..70938374 100644
--- a/extra/linux-zen/config
+++ b/extra/linux-zen/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.17.8-1 Kernel Configuration
+# Linux/x86 4.17.11-zen1 Kernel Configuration
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
diff --git a/extra/nvidia-390xx-lts/PKGBUILD b/extra/nvidia-390xx-lts/PKGBUILD
index 9775a96a..f7aa47dc 100644
--- a/extra/nvidia-390xx-lts/PKGBUILD
+++ b/extra/nvidia-390xx-lts/PKGBUILD
@@ -5,7 +5,7 @@ for ((i=${#source[@]}; i>0; i--)); do
done
source[${i}]="http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run"
-sha512sums[${i}]='177ad1a4ae52fc00001461e65e264fe9f9bf0dc5e8974391311cb80f8bcfa309f12bf1bcb4b162684a01416cfbbaa76d3b81dff3fb08ff2f5e8644255cc22987'
+sha512sums[${i}]='470e1e71079f4838bc842c2779f7c32c26c37ff30a0d3719d9e534ff0b71775fdf40446766c06505bffc404bfd6871e4f101de4727380418dda0d084e5637bf8'
_pkg="NVIDIA-Linux-x86-${pkgver}"
eval "$(
diff --git a/extra/nvidia-390xx-utils/PKGBUILD b/extra/nvidia-390xx-utils/PKGBUILD
index 97fe68df..811ef880 100644
--- a/extra/nvidia-390xx-utils/PKGBUILD
+++ b/extra/nvidia-390xx-utils/PKGBUILD
@@ -8,7 +8,7 @@ for ((i=${#source[@]}; i>0; i--)); do
fi
done
source[${i}]="http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run"
-sha512sums[${i}]='177ad1a4ae52fc00001461e65e264fe9f9bf0dc5e8974391311cb80f8bcfa309f12bf1bcb4b162684a01416cfbbaa76d3b81dff3fb08ff2f5e8644255cc22987'
+sha512sums[${i}]='470e1e71079f4838bc842c2779f7c32c26c37ff30a0d3719d9e534ff0b71775fdf40446766c06505bffc404bfd6871e4f101de4727380418dda0d084e5637bf8'
eval "$(
declare -f package_nvidia-390xx-utils | \
diff --git a/extra/nvidia-390xx/PKGBUILD b/extra/nvidia-390xx/PKGBUILD
index 39356b93..78ee510b 100644
--- a/extra/nvidia-390xx/PKGBUILD
+++ b/extra/nvidia-390xx/PKGBUILD
@@ -5,7 +5,7 @@ for ((i=${#source[@]}; i>0; i--)); do
done
source[${i}]="http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run"
-sha256sums[${i}]='6f4af70ee3d03ed31c497a5d555164c56057b53ecedfc0d2c8de4b0b90728805'
+sha256sums[${i}]='1445d22b987daca15bf313b39d08aca4cec71dd473f1d20eb00b0b08df08a3f9'
_pkg="NVIDIA-Linux-x86-${pkgver}"
eval "$(