summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/python/PKGBUILD53
1 files changed, 0 insertions, 53 deletions
diff --git a/extra/python/PKGBUILD b/extra/python/PKGBUILD
deleted file mode 100644
index 1880d300..00000000
--- a/extra/python/PKGBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# tests run with -j4 per default effectively killing build slaves,
-# forcing single threaded execution of tests
-
-eval "$(
- declare -f build | \
- sed "
- s/make /make EXTRATESTOPTS='-j 1' /
- "
-)"
-
-eval "$(
- declare -f check | \
- sed "
- s/ -m test.regrtest/ -m test.regrtest -j1/
- "
-)"
-
-makedepends=(${makedepends[@]//xorg-server-xvfb/})
-makedepends_i686+=(xorg-server-xvfb)
-makedepends_pentium4=("${makedepends_i686[@]}")
-
-# skip xvfb stuff on i486
-if [ "$CARCH" = 'i486' ]; then
- eval "$(
- declare -f build | \
- sed '
- /export servernum=99/,/done/d
- s/.*make/make/
- '
- )"
- eval "$(
- declare -f check | \
- sed '
- /export servernum=99/,/done/d
- s/xvfb-run -s "-screen 0 1920x1080x16 -ac +extension GLX" -a -n "$servernum"//
- '
- )"
-fi
-
-# ignore failing realtime scheduling test as the systemd-nspawn container
-# lacks the SYS_NICE capability (at least, I think so)
-# ERROR: test_sched_rr_get_interval (test.test_posix.PosixTester)
-# Bonus points for finding the option to ignore single tests in test_posix
-# test_gdb currently fails for unknown reasons, also not that important
-# test_socket tests take more than 1.5 hours, so ignoring them
-# Ignore test_cmath test_math test_turtle - they fail due to too low precision
-# on i686 (all of them - really? - actually, I just checket test_cmath)
-eval "$(
- declare -f check | \
- sed "
- /-uall/ s/;\?$/ -x test_posix -x test_gdb -x test_socket -x test_cmath -x test_math -x test_turtle \\|\\| true/g
- "
-)"