summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/texmacs/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/texmacs/PKGBUILD b/extra/texmacs/PKGBUILD
new file mode 100644
index 00000000..6469e015
--- /dev/null
+++ b/extra/texmacs/PKGBUILD
@@ -0,0 +1,10 @@
+# guile cmake checks allow int* to be casted to size_t*, so we
+# add -fpermissive to make the int cast fail and the size_t cast
+# succeed
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /cd TeXmacs-${pkgver}-src/ a \ sed -i "/SET(CMAKE_REQUIRED_FLAGS/s/-Werror /-Werror -fpermissive /" CMakeLists.txt
+ '
+)"