summaryrefslogtreecommitdiff
path: root/extra
diff options
context:
space:
mode:
Diffstat (limited to 'extra')
-rw-r--r--extra/qemu/PKGBUILD11
-rw-r--r--extra/qemu/qemu-2.11.1-glibc-2.27-mman_create.patch26
2 files changed, 37 insertions, 0 deletions
diff --git a/extra/qemu/PKGBUILD b/extra/qemu/PKGBUILD
index 0ccb8f88..3a862424 100644
--- a/extra/qemu/PKGBUILD
+++ b/extra/qemu/PKGBUILD
@@ -13,3 +13,14 @@ eval "$(
s@rm qemu/block-{iscsi,rbd,gluster}.so@rm qemu/block-{iscsi,gluster}.so@
'
)"
+
+# see https://git.qemu.org/?p=qemu.git;a=commit;h=75e5b70e6b5dcc4f2219992d7cffa462aa406af0
+source+=('qemu-2.11.1-glibc-2.27-mman_create.patch')
+sha256sums+=('5653219a0d4ff8312e7bc4a5f6202ae637607e114e68d4c9fcf8492ab23706bb')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /allow_elf64.patch/a patch -Np1 -i ../qemu-2.11.1-glibc-2.27-mman_create.patch
+ '
+)"
diff --git a/extra/qemu/qemu-2.11.1-glibc-2.27-mman_create.patch b/extra/qemu/qemu-2.11.1-glibc-2.27-mman_create.patch
new file mode 100644
index 00000000..6b0f283d
--- /dev/null
+++ b/extra/qemu/qemu-2.11.1-glibc-2.27-mman_create.patch
@@ -0,0 +1,26 @@
+diff -rauN qemu-2.11.1/configure qemu-2.11.1-glibc-2.27-mman_create-patch/configure
+--- qemu-2.11.1/configure 2018-02-14 22:53:22.000000000 +0100
++++ qemu-2.11.1-glibc-2.27-mman_create-patch/configure 2018-05-01 08:12:01.052175589 +0200
+@@ -3920,7 +3920,7 @@
+ # check if memfd is supported
+ memfd=no
+ cat > $TMPC << EOF
+-#include <sys/memfd.h>
++#include <sys/mman.h>
+
+ int main(void)
+ {
+diff -rauN qemu-2.11.1/util/memfd.c qemu-2.11.1-glibc-2.27-mman_create-patch/util/memfd.c
+--- qemu-2.11.1/util/memfd.c 2018-02-14 22:53:23.000000000 +0100
++++ qemu-2.11.1-glibc-2.27-mman_create-patch/util/memfd.c 2018-05-01 08:13:37.393396612 +0200
+@@ -31,9 +31,7 @@
+
+ #include "qemu/memfd.h"
+
+-#ifdef CONFIG_MEMFD
+-#include <sys/memfd.h>
+-#elif defined CONFIG_LINUX
++#if defined CONFIG_LINUX && !defined CONFIG_MEMFD
+ #include <sys/syscall.h>
+ #include <asm/unistd.h>
+