summaryrefslogtreecommitdiff
path: root/extra/webkit2gtk
diff options
context:
space:
mode:
Diffstat (limited to 'extra/webkit2gtk')
-rw-r--r--extra/webkit2gtk/PKGBUILD27
-rw-r--r--extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch22
2 files changed, 49 insertions, 0 deletions
diff --git a/extra/webkit2gtk/PKGBUILD b/extra/webkit2gtk/PKGBUILD
new file mode 100644
index 00000000..8f368200
--- /dev/null
+++ b/extra/webkit2gtk/PKGBUILD
@@ -0,0 +1,27 @@
+# disable SSE2 on 486 and 686
+if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
+ source+=('webkitgtk-2.24.1-no-sse2.patch')
+ sha256sums+=('37b6ecf3918415fc0ad6662ea66ee77bf96c5343fcd80a243395e92b022b2d4e')
+
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /cd.*/a patch -p1 < ../webkitgtk-2.24.1-no-sse2.patch
+ '
+ )"
+fi
+
+# work around broken generated makefiles resulting in
+# "make[2]: *** No rule to make target 'JavaScriptCore-4.0.gir', needed by 'WebKit2-4.0.gir'. Stop."
+if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
+
+ eval "$(
+ declare -f build | \
+ sed '
+ /cmake --build build/a \
+ cd build && make JavaScriptCore-4-gir && cd .. \
+ cmake --build build
+ s/\(cmake --build build\)/\1 || true/g
+ '
+ )"
+fi
diff --git a/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch b/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch
new file mode 100644
index 00000000..ffc2c6b3
--- /dev/null
+++ b/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch
@@ -0,0 +1,22 @@
+diff -rauN webkitgtk-2.24.1/Source/WebCore/platform/audio/VectorMath.cpp webkitgtk-2.24.1-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp
+--- webkitgtk-2.24.1/Source/WebCore/platform/audio/VectorMath.cpp 2019-02-12 12:21:18.000000000 +0100
++++ webkitgtk-2.24.1-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp 2019-05-17 14:43:51.042171245 +0200
+@@ -33,6 +33,7 @@
+ #endif
+
+ #if CPU(X86_SSE2)
++#define No SSE2
+ #include <emmintrin.h>
+ #endif
+
+diff -rauN webkitgtk-2.24.1/Source/WTF/wtf/Platform.h webkitgtk-2.24.1-no-sse2-patch/Source/WTF/wtf/Platform.h
+--- webkitgtk-2.24.1/Source/WTF/wtf/Platform.h 2019-03-05 16:32:47.000000000 +0100
++++ webkitgtk-2.24.1-no-sse2-patch/Source/WTF/wtf/Platform.h 2019-05-17 14:17:45.508210181 +0200
+@@ -124,6 +124,7 @@
+ #define WTF_CPU_KNOWN 1
+
+ #if defined(__SSE2__) || (defined(_M_IX86_FP) && _M_IX86_FP >= 2)
++#error No SSE2
+ #define WTF_CPU_X86_SSE2 1
+ #endif
+