summaryrefslogtreecommitdiff
path: root/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch')
-rw-r--r--extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch b/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch
index ffc2c6b3..9fdac3cc 100644
--- a/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch
+++ b/extra/webkit2gtk/webkitgtk-2.24.1-no-sse2.patch
@@ -1,3 +1,25 @@
+diff -rauN webkitgtk-2.24.1/CMakeLists.txt webkitgtk-2.24.1-no-sse2-patch/CMakeLists.txt
+--- webkitgtk-2.24.1/CMakeLists.txt 2019-04-08 12:45:38.000000000 +0200
++++ webkitgtk-2.24.1-no-sse2-patch/CMakeLists.txt 2019-05-19 12:33:45.378203751 +0200
+@@ -109,12 +109,12 @@
+ #---------------------------
+ # Make sure SSE2 is present.
+ #---------------------------
+-if (WTF_CPU_X86)
+- include(FindSSE2)
+- if (NOT SSE2_SUPPORT_FOUND)
+- message(FATAL_ERROR "SSE2 support is required to compile WebKit")
+- endif ()
+-endif ()
++#if (WTF_CPU_X86)
++# include(FindSSE2)
++# if (NOT SSE2_SUPPORT_FOUND)
++# message(FATAL_ERROR "SSE2 support is required to compile WebKit")
++# endif ()
++#endif ()
+
+ # -----------------------------------------------------------------------------
+ # Determine the operating system
diff -rauN webkitgtk-2.24.1/Source/WebCore/platform/audio/VectorMath.cpp webkitgtk-2.24.1-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp
--- webkitgtk-2.24.1/Source/WebCore/platform/audio/VectorMath.cpp 2019-02-12 12:21:18.000000000 +0100
+++ webkitgtk-2.24.1-no-sse2-patch/Source/WebCore/platform/audio/VectorMath.cpp 2019-05-17 14:43:51.042171245 +0200