summaryrefslogtreecommitdiff
path: root/extra/python2
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python2')
-rw-r--r--extra/python2/PKGBUILD22
1 files changed, 5 insertions, 17 deletions
diff --git a/extra/python2/PKGBUILD b/extra/python2/PKGBUILD
index 519a683a..5b876d5a 100644
--- a/extra/python2/PKGBUILD
+++ b/extra/python2/PKGBUILD
@@ -3,32 +3,20 @@
# test_unicode, test_userstring) segfault on i686
# test_bigrepeat (present in test_tuple) segfault on i686
+# tests run with -j4 per default effectively killing build slaves,
+# forcing single threaded execution of tests
+
eval "$(
declare -f build | \
sed '
/export OPT=/ s/";$/ -fwrapv";/
+ s/make/make EXTRATESTOPTS='"'"'-j 1'"'"' /
'
declare -f check | \
sed '
/xvfb-run/ s/-x test_idle/-x test_idle test_bytes test_str test_string test_unicode test_userstring test_tuple/
- '
-)"
-
-# tests run with -j4 per default effectively killing build slaves,
-# forcing single threaded execution of tests
-
-eval "$(
- declare -f build | \
- sed "
- s/make/make EXTRATESTOPTS='-j 1' /
- "
-)"
-
-eval "$(
- declare -f check | \
- sed "
s/ -m test.regrtest/ -m test.regrtest -j1/
- "
+ '
)"
makedepends=(${makedepends[@]//xorg-server-xvfb/})